closing a tab doesn't return to the last shown tab

RESOLVED DUPLICATE of bug 345033

Status

()

--
major
RESOLVED DUPLICATE of bug 345033
11 years ago
9 years ago

People

(Reporter: hr333, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

When multiple are tabs opened,
showing a tab (which is *not* the right most tab),
opening a new tab (in the background by midlle-mousbutton-clicking, then bringing this tab to front by clicking on the tab),
and then closing this new tab again
does not return to the last-viewed tab. 
Instead, the right most tab is displayed.


Reproducible: Always

Steps to Reproduce:
1. Open Firefox 
2. In Options -> Tabs -> uncheck "When I open a link in a new tab, switch to it immediately"
2. Navigate to a website with links
3. open some links in new tabs in background 
4. bring the last opened tab opened tab to front by clicking on it
5. close this tab
Actual Results:  
you see the roght most tab


Expected Results:  
see the tab I was before


My firefox is set to open new tabs in the background. 
When enabling "When I open a link in a new tab, switch to it immediately" under Options/Tabs, this bug doesn't appear, i.e. when closing a tab the previosly shown tab is shown again.

Updated

10 years ago
Blocks: 345028
I cannot find another bug on this issue. So lets confirm with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090901 Namoroka/3.6a2pre ID:20090901173911
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → 2.0 Branch
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 344508

Comment 3

9 years ago
It's more obviously a dupe of bug 345033.
(In reply to comment #3)
> It's more obviously a dupe of bug 345033.

Yes, thanks for pointing to it.
Duplicate of bug: 345033
You need to log in before you can comment on or make changes to this bug.