Windows always open maximized

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: noisebar, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

New windows are always opened maximized.  Even if I resize the window and quit, the next time I start Firefox the windows are still maximized.

Reproducible: Always

Steps to Reproduce:
1. Simply open new Firefox window in OS X.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
Is nobody looking into this?
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Why was this marked as fixed?  I still see it w/ 3.0RC1 (Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0)
(Reporter)

Comment 3

11 years ago
I was the original reporter on this.  It somehow disappeared for me.  I haven't been able to reproduce it.
I removed localstore.rdf from my profile and the problem went away.  Something from the upgrade from 2.0.0.14 to 3.0rc1 must have frozen the width/height entries in localstore.rdf, I suppose, but removing the storage file fixed it.

The bug should really be marked as WORKSFORME since there was no actual fix made to the firefox code.
You need to log in before you can comment on or make changes to this bug.