In location bar autocomplete ignore results with a particular tag (like "private") to help users protect their privacy

RESOLVED DUPLICATE of bug 450314

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 450314
10 years ago
2 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Several users have commented that they like the new location bar autocomplete, but that they are concerned that it is showing bookmarks for certain sites that that could cause embarrassment if displayed.  Users have also noticed that the large and easy to read font we are using for page or bookmark titles makes it easier for other people to see this information as well.

What if we didn't show any results in the user's bookmarks that contained the tag "private."  Even after we implemented private browsing mode, this feature would be useful for users that want to bookmark a page, but not have firefox repeat that bookmark back to them.
Not for Fx3, but a good target for the future.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
(Reporter)

Updated

10 years ago
Summary: Ignore results with a particular tag to help users protect their privacy? → In location bar autocomplete ignore results with a particular tag (like "private") to help users protect their privacy
Duplicate of this bug: 422944
Apparently bug 395161 makes this easier.
(Reporter)

Updated

10 years ago
Duplicate of this bug: 437055

Comment 5

10 years ago
It would be important to implement this feature for the launch date of Firefox 3. Many people I know will not install this version by this "problem of privacy."

Comment 6

9 years ago
What would be the UI for this feature? / How would it be discovered?

Also, what is the migration path? Can people just tag a whole folder of bookmarks after they upgrade or do they have to do it one by one?
(Reporter)

Comment 7

9 years ago
>What would be the UI for this feature? / How would it be discovered?

funny you should ask, I just finished the mockup for specifying tags a few minutes ago: 

http://people.mozilla.com/~faaborg/files/shiretoko/privacy_i2.png

>Can people just tag a whole folder of
>bookmarks after they upgrade or do they have to do it one by one?

We are probably going to add a checkbox to folders under their properties to exclude them from the location bar autocomplete.

We should also have support for tagging multiple bookmarks in the Library window.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450314

Updated

9 years ago
Flags: blocking-firefox3-
You need to log in before you can comment on or make changes to this bug.