Closed Bug 422162 Opened 12 years ago Closed 11 years ago

Danish Firefox/Thunderbird should include Hunspell dictionary by default - Stavekontrolden is better and has tri-license

Categories

(Mozilla Localizations :: da / Danish, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 

Should we include Stavekontrolden in Firefox 3? Some questions needs to be answered:

Is it of better quality than DSDO?

Is the Hunspell library used in Firefox 3, I don't remember?

How does a built-in dictionary coexist with an addon?

How is upgrading from Firefox 2 to Firefox 3 going to work with this change?

Related to the two questions above: How do we ensure that Firefox uses the newest version if there is both a built-in dictionary and an addon installed?

Which files should be added/changed in CVS?

In case you are not part of the Danish l10n team, you probably need some background information:

The DSDO dictionary:
Name: Den Store Danske Ordliste (DSDO)
Home page: http://da.speling.org/
File format: Aspell, Ispell and Myspell
License: GPL 2
Owner: SSLUG (Skåne Sjælland Linux User Group)

The Stavekontrolden dictionary:
Name: Stavekontrolden
Home page: http://www.stavekontrolden.dk/
File format: Hunspell
License: GPL 2, LGPL 2.1 and MPL 1.1
Owner: Association for freely available language tools

Stavekontrolden was created by the Danish OpenOffice.org l10n community mainly for two reasons:
* Incompatibility between the OpenOffice.org license and the DSDO license
* Concerns about the quality of DSDO


Reproducible: Always
Blocks: fx3-l10n-da
Wil, can you offer an opinion on the question about built-in and add-on. i don't believe there would be a conflict?
Jesper, are you suggesting adding this as a new search engine for da?
search engine? I don't understand. This is a spell checking dictionary.
Comments:

Ignore comment 1 ;-)

Yes, we use hunspell.

Update for fx2 to 3 should just work.

I don't know what happens if you had both dsdo and stavekontrolden installed. You'll need to just test that.

I can't of course say anything about the quality of either.
Status: UNCONFIRMED → NEW
Ever confirmed: true
axel comment #3, i don't understand - are we proposing including a dictionary as a search plug in or something else?
Mic, this has nothing to do with search. This is spellchecking dictionaries.
(In reply to comment #1)
> Wil, can you offer an opinion on the question about built-in and add-on. i
> don't believe there would be a conflict?
> Jesper, are you suggesting adding this as a new search engine for da?
> 

An add-on is easy to add/remove and it would help us get some feedback on the quality.
> An add-on is easy to add/remove and it would help us get some feedback on the
> quality.

It was too big for bugzilla, so I will post a link instead:
http://filer.mozilladanmark.dk/bug422162_test_dict.xpi
As creator of the Danish dictionary (only the XPI), I would recommend switching to Stavekontrolden, but not for Firefox 3. It's too late.

We should test Stavekontrolden in the Danish l10n group. If it works better, then change XPI and include Stavekontrolden by default in Danish Firefox 3.5/4.
(In reply to comment #8)
> As creator of the Danish dictionary (only the XPI), I would recommend switching
> to Stavekontrolden, but not for Firefox 3. It's too late.
> 
> We should test Stavekontrolden in the Danish l10n group. If it works better,
> then change XPI and include Stavekontrolden by default in Danish Firefox 3.5/4.
> 

We should not change the addon on AMO before the Firefox 2 and Thunderbird 2 branches are dead because they use myspell.

I agree that it is a little late.
This is not something we need to fix for Firefox 3.0, but we can certainly start shipping the stavekontrolden dictionary as part of a minor update.

We should have tested how having both the 2.0 myspell dictionary and the stavekontrolden one installed works, though. In particular when building the latter the way the regular build system would package it up.
If we decide to not block Firefox 3 on this, we should unblock the fx3 release bug from this one.
No longer blocks: fx3-l10n-da
(In reply to bug 415581 comment #7)
> Any news on the dictionary?

Now that Firefox 3 is shipped with support for hunspell, we should get a beta add-on out for wider testing.

I don't think I have seen answers on all the technical questions.
I have uploaded a new version:

http://filer.mozilladanmark.dk/stavekontrol/dansk-ordbog-2.0b1.xpi

Changes from last one:
Version number is 2.0b1
ID is the same as the dictionary on AMO
Contains updated list from stavekontrolden

søren, hansen etc: Should we put a link to it in our forum or other places on our site asking for feedback? What do you think of it yourself? Is it good enough to include in Firefox/Thunderbird 3? I think so, but I would like to hear other peoples opinion.
Mind doing the following:

Install Firefox 3, install the old dictionary extension in the profile. Create a Danish Fx3.1 test build with the new dictionary in place in extensions/spellcheck/hunspell, install that over your fx3 install.

Check what happens with the old dictionary, and if the new one works like you'd expect.
Thanks Axel. I'm working on that this week. Also what to do with the current addon, when people are upgraded to 3.1.

I'll return with more information. Jesper is helping me too, but I'm sure we'll get it working.
Not sure what to do with existing installs. I guess you could try to install your new dictionary in your profile, too, and see what happens if you have two danish dicts.
Now that the Danish Firefox 3.1 nightlies are green, I would like to get this one fixed.

> Is it of better quality than DSDO?
From what I remember, I think there is agreement that Stavekontrolden is better or at least as good as DSDO.

> Is the Hunspell library used in Firefox 3, I don't remember?
Firefox 2 and Thunderbird 2 does not support hunspell, so we cannot change the dictionary on addons.mozilla.org when people are still using Thunderbird 2.

> How does a built-in dictionary coexist with an addon?
Two dictionary addons for the same language can be installed at the same time without any problem. Only one of them will be used and visible. We don't know which one. This is probably the same for a built in dictionary and an addon dictionary.

There was some confusion about how the dictionary is installed. It is installed as any other addon in the profile folder. The install.js file in the xpi is only used by Seamonkey 1.x. So there should be no problems in Firefox and Thunderbird.

> How is upgrading from Firefox [3.0] to Firefox [3.1] going to work with this change?
Without a problem.

> Related to the two questions above: How do we ensure that Firefox uses the
> newest version if there is both a built-in dictionary and an addon installed?
We don't know which one will be used. Maybe we can do some magic in the addon (it could uninstall or disable itself if a newer built-in version is found), but that can be done independently of this bug, and it should not delay this bug in any way. If the wrong dictionary is used, it won't break anything, it will just be status quo, and we can fix that later.

> Which files should be added/changed in [hg]?
What other locales did:
http://mxr.mozilla.org/l10n-central/find?string=hunspell

So what is next?
I guess hansen knows best which dic and aff file from Stavekontrolden is the best one for us. Then Søren can just check in these files, and we can get a build to play with.
Summary: Think about inclusion of Stavekontrolden spell checking dictionary in Danish Firefox 3 → Danish Firefox/Thunderbird should include Hunspell dictionary by default - Stavekontrolden is better and has tri-license
Stavekontrolden has been checked in and will be shiped by default from Firefox 3.5 onwards ;-D
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.