Smooth Scrolling not so smooth when using scroll wheel with flash content (plugins) in the page

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
11 years ago
6 years ago

People

(Reporter: will, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

When I have smooth scrolling turned on and I use my scroll wheel on my mouse to scroll a page scrolling is smooth as silk until I hit a flash ad.  I did some testing and it appears when plugin content (aka flash, quicktime, etc) is rendered on screen smooth scrolling gets slow.

Reproducible: Always

Steps to Reproduce:
1. Go to macsurfer.com
2. verify they have flash ads showing
3. scroll page with smooth scrolling turned on with your mouse's scroll wheel

Actual Results:  
While the flash ad is visible on screen, scrolling is slowed.  When it leaves the screen scrolling is fast and smooth. 

Expected Results:  
smooth scrolling to be smooth all the time.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 3

6 years ago
I have the same problem but it doesn't always happen. FF version is 13.0.1 with enabled smooth scrolling.
When I said it didn't always happen I meant it seems to happen only when a flash video is embedded in a forum post. When scrolling vertically in a forum topic which contains one or more embedded videos, those videos appear... broken, for the lack of a better word. And also if there's any text and animated emoticons, those appear twice and the emoticons are split into at least 2 frames. I made 2 screenshots in order to explain the problem better.
Image 1: http://www10.pic-upload.de/24.06.12/klc3gn3jz8.jpg
Image 2: http://www7.pic-upload.de/24.06.12/14jsb5b7z3k.jpg
The videos on the screenshots are from YouTube but that happens if the videos are from another site as well. Like vbox7.com, for instance.
You need to log in before you can comment on or make changes to this bug.