Stylesheet with 'application/octet-stream' mime header doesn't load

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Eric Landy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Setting IIS 6 to return a MIME type of 'application/octet-stream' for all files seems to prevent firefox from loading the stylesheet (set properly in the <head> e.g. <link rel="stylesheet" type="text/css" href="stylesheet.css" />)
(works fine in MS IE).
Removing the MIME type for all files seems to work normally.


Reproducible: Always

Steps to Reproduce:
1. Add a new MIME type for '.*' 'application/octet-stream' in IIS.
2. create html page pulling stylesheet
3. load html page from iis.
Actual Results:  
page loaded but stylesheets didn't.

Expected Results:  
loaded the stylesheets.
(Reporter)

Updated

10 years ago
Summary: Stylesheet with 'application/octet-stream' mime header doesn't load (except if processed thru third-party plugin like 'web developer 1.1.4') → Stylesheet with 'application/octet-stream' mime header doesn't load
That is no bug if your server sends the Stylesheet not as text/css, it's expected and you can also see in the Firefox error Console that such a stylesheet is rejected. The mimetypoe from the server overrides the type attribute.
The Http RFC is followed in this case.
You have to write a bug for IE that it accepts such broken Mime-type.


Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 2

10 years ago
Hello my name is Symion.

I currently have primusonline as my ISP!

I have a problem with CSS validation, FF2.xx will not validate the CSS files I want to use for my personal web page, at:     >>>>http://home.primusonline.com.au/knoware/index.htm<<<<

When I check FF2-Tools-Error Console. I find the following error messages.

This happens once, when I first run FF2.xx
******
Warning: Warning: Unrecognized chrome registration modifier 'contentaccessible=yes'.
Source File: file:///C:/Documents%20and%20Settings/derek/Application%20Data/Mozilla/Firefox/Profiles/mk7ucz4m.symion/extensions/%7Bc33c5b47-69c8-45a4-a5e0-af85bbe628dd%7D/chrome.manifest
Line: 4
******

This happens whenever I access my website.
******
Error: The stylesheet http://home.primusonline.com.au/knoware/books/cjavass/base-6.css was not loaded because 
its MIME type, "text/plain", is not "text/css".
Source File: http://home.primusonline.com.au/knoware/books/frontpage.htm
Line: 0
******

Frontpage.htm is the next program that index.htm runs. It is also the first time I use File Based CSS!
I have tracked down the BUG (after many hours of fruitless fiddling with my code) to a Server side problem!

My problem seems to have begun whem I decided to 'up-grade' to  Firefox 3.xx
After trying out FF3, I then decided that it realy was not an improvement over FF3, 
but had some teething problems.

These include:
  1. FF3 does not allow most of my Add-ons to function.
  2. The vertical scroll, either by keyboard or scroll bar is painfully slow and jittery.
      I have lots of images and multiple back-grounds, so it matters!
  3. Every time I move my mouse cursor over a 'linked text' that I have previously clicked on, 
      the mouse 'sticks', for an instant, when entering and when leaving.
      It does not do this with any 'linked text' that I have not yet gone to, only ones I have been to.
  4. This is a personal choice type thing. 
      I really dislike the Big fat red border that surrounds linked images, it reminds me of IE (gag)
      And I don't know how to get rid of, or change it.

So, for these reasons I decided to go 'back' to FireFox 2.xx!!

The problem began when I tried to access my personal web-site.

Apparently primusonline have a bug in their server, at least when it comes to My Web-Page, 
but NOT for any other web-sites I visit.
So after contacting them, they say there is no problem on their side, so it must be Mozilla Firefox.
Now this seems a bit like 'Shooting the Messenger'!

IE simply notes the error and continues on, it makes a reasonable assumption that a file that returns a MIME type 
text/plain instead of text/css, is probably a valid css file, and allows access to it!

They also suggested that I use IE, because the error does not seem to effect its performance, unlike FF2.xx!

Please understand, I am not complaining about a defect in FireFox, everything seems to work fine, 
but rather a Decision that increases the Strictness to Rules that FF2 developers have chosen, 
and how this gives IE an unwarranted advantage over FF.

Informing me that an error with MIME Types is excellent, but applying a Harsh response is Not good!

The ideal solution is of course for primusonline to get their act together and fix the bug!

But equally, in a race for supremacy, Firefox has to be able to equal and surpass the competition.
By forming me of a bug but prohibiting access because its 'against the rules', is unnecessarily harsh.
Perhaps a pop-up that informs me of this problem and allows Me to decide Yae or Nae, would be a good compromise?

My only other solution is to change ISP, as I would not like to go back to IE!

3:54 PM Monday, July 21, 2008

Symion
You need to log in before you can comment on or make changes to this bug.