GIF does not restart animation when opened in new tab.

RESOLVED DUPLICATE of bug 129986

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 129986
10 years ago
8 years ago

People

(Reporter: James, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3pre) Gecko/2008020509 Firefox/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3pre) Gecko/2008020509 Firefox/3.0b3pre

When viewing an animated GIF, the GIF will not restart from its initial state unless a full browser-cache wipe is initiated (ctrl+f5). Furthermore, if the GIF is opened in another tab or posted to a web page, it continues its state from the time it was initially viewed (on the previous page), rather then starting from its initial frame of animation. 

Reproducible: Always

Steps to Reproduce:
1.Open http://img249.imageshack.us/img249/8984/1zx6tttpp4.gif
2. Refresh the page. Gif will not revert to frame 1. 
3. Open a new tab and view the image again. It will be at the same time-state as the initial viewing of the gif in the previous tab.
3. Ctrl+f5, Gif will start from frame 1.
Actual Results:  
The Gif continues from its initially viewed frame-state. 

Expected Results:  
The Gif should restart from frame-state 1 of animation

Comment 1

9 years ago
This is still an issue and seriously effects something I want to do on a website,
works fine in Microsoft Internet Explorer, Safari and Google Chrome,

Why not Firefox?

Comment 2

8 years ago
Duplicate of Core bug 129986?
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 3.0 Branch

Comment 4

8 years ago
Still experiencing this issue

Tested just now in safe mode

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129986
You need to log in before you can comment on or make changes to this bug.