Checkbox in a title in a titlebox does not update properly.

VERIFIED DUPLICATE of bug 41267

Status

()

Core
XUL
P3
major
VERIFIED DUPLICATE of bug 41267
18 years ago
10 years ago

People

(Reporter: Joseph Elwell, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I've got a bugscape bug that is blocked because I've got a checkbox
inside a title inside a titlebox that won't update properly when checked
on. The oncommand is being called, but the display is not updated unless
I grab another window (say notepad) and move notepad over the current
window, then away. This forces the update on the xul.

Other xul elements act very strange. Try for instance a textfield.

Here's a sample piece of code that exhibits the checkbox problem that
I'm seeing (If you move the </title> up one line the problem goes away,
this was tested on winNT comm bits - using viewer) (Will attach):


<?xml version="1.0"?>
<?xml-stylesheet href="chrome://communicator/skin/" type="text/css"?>

<window xmlns:html="http://www.w3.org/TR/REC-html40"
class="color-dialog"
xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
orient="vertical">

<titledbox>
<title>
<checkbox id="proxyUse" value="Nothing"/>
</title>
</titledbox>
</window>
(Reporter)

Comment 1

18 years ago
Created attachment 9981 [details]
testcase - same as inline code.

Comment 2

18 years ago
This is a dup of an nsbeta2+ 6/15 bug.

*** This bug has been marked as a duplicate of 41267 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
marking verified.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.