Consistently get CGBitmapContextCreateImage: invalid context Errors in console

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: marcia, Assigned: vlad)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031104 Minefield/3.0b5pre.

STR:
1. Open console.app and run it while you are running the nightly.
2. Observe numerous instances of the CGBitmapContextCreateImage: invalid context 
error message during your session.

This was reported in hendrix as well. Not sure if it is important, but just raising it since it is seen consistently on the nightly and in B4.
Cairo and cocoa native theming are the only callers of that function in our tree.
Assignee: nobody → joshmoz
Component: General → Widget: Cocoa
Product: Firefox → Core
QA Contact: general → cocoa
Safe and ignorable, will go away (yay private APIs!) once I upgrade cairo.  (I actually thought I already fixed this, but turned out I fatfingered a function name, so the private function I was looking for was never present.  Go me.)
Assignee: joshmoz → vladimir
Depends on: 421422
Should be fixed (for real this time) by the cairo upgrade.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 423455
You need to log in before you can comment on or make changes to this bug.