with caldav calendars, on all days that have multiple events, only the last event is shown

RESOLVED INVALID

Status

Calendar
Provider: CalDAV
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Martin Muc, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12
Build Identifier: lightning-0.7-tb-linux-x86_64.xpi

I have a problem with a large calendar served on my Davical (rscds) server.  On all the days that had multiple events, it showed only the last event when looking at Day view, Week view, Multiweek, or Month view.

I've tested this and found it to be a problem in:
v0.5 of Lightning (64 bit Ubuntu)
v0.7 of Lightning (64 bit Ubuntu)
v0.7 of Lightning (32 bit Ubuntu)
v0.5 of Sunbird (64 bit Ubuntu)

Though strangely, in the Sunbird example, all the events are correctly shown in the text-based pane above the Day/Week/etc pane, so I suspect (in all cases) the data are "there" somewhere, just not rendered correctly.

I have condensed it down to a fairly minimal test file.  You should see 1 event on March 3, and 5 events on March 4.  It works fine if you save/import this as a local ics file.  But if a caldav server generates/sends you this exact same file, you only see 2 events (1 on Mar 3, and the 4:00pm one on Mar 4).


BEGIN:VCALENDAR
PRODID:-//Catalyst.Net.NZ//NONSGML AWL Calendar//EN
VERSION:2.0
X-WR-CALNAME:bug test
BEGIN:VEVENT
SUMMARY:Anthony to Sierra
DTSTART;VALUE=DATE:20080303T130000
DTEND;VALUE=DATE:20080303T133000
DESCRIPTION:
END:VEVENT
BEGIN:VEVENT
SUMMARY:Anthony to seminar
DTSTART;VALUE=DATE:20080304T073000
DTEND;VALUE=DATE:20080304T080000
DESCRIPTION:A Blueprint for Building Green
END:VEVENT
BEGIN:VEVENT
SUMMARY:Martin or Alex call Ron
DTSTART;VALUE=DATE:20080304T100000
DTEND;VALUE=DATE:20080304T103000
DESCRIPTION:see how he managed on Thursday.
END:VEVENT
BEGIN:VEVENT
SUMMARY:Anthony call Greg
DTSTART;VALUE=DATE:20080304T130000
DTEND;VALUE=DATE:20080304T133000
DESCRIPTION:at his office
END:VEVENT
BEGIN:VEVENT
SUMMARY:Tony - Stars
DTSTART;VALUE=DATE:20080304T153000
DTEND;VALUE=DATE:20080304T160000
DESCRIPTION:Meet with Sue
END:VEVENT
BEGIN:VEVENT
SUMMARY:Martin phone meeting with Justin
DTSTART;VALUE=DATE:20080304T160000
DTEND;VALUE=DATE:20080304T170000
DESCRIPTION:Justin interest from 2008
END:VEVENT
END:VCALENDAR


Not sure if it matters, but this was via a https caldav URL, requiring user and password.


Reproducible: Always

Actual Results:  
only 2 events shown, one on each day

Expected Results:  
6 events should be shown, 1 on Mar 3, and 5 on Mar 4.
(Reporter)

Comment 1

10 years ago
Created attachment 309150 [details]
.ics file that fails (no UIDs)
(Reporter)

Comment 2

10 years ago
Created attachment 309151 [details]
.ics file that works (same as first attachment except it has UIDs)
(Reporter)

Comment 3

10 years ago
The working test (same as problem file except with UIDs added) was only tested on v0.5 of Sunbird (64 bit Ubuntu).
(Reporter)

Comment 4

10 years ago
This is strange, the RFC page 52 says uid is optional, but page 110 says it "MUST" be present.  http://www.ietf.org/rfc/rfc2445.txt  I'm no expert are RFC semantics, so if anyone that is an expert can interpret that, then...

if it really is optional, then please investigate/fix the bug...

if it really must be present, then I apologize for the false alarm, I suppose lower the bug priority but it would still be good to handle it more gracefully.
Seems to be corrected in the 2445 update:
<http://tools.ietf.org/html/draft-ietf-calsify-rfc2445bis-08> Page 54:

  eventprop  = *(
                     ; the following are REQUIRED,
                     ; but MUST NOT occur more than once
  
                     dtstamp / dtstart / uid /

This means the .ics file is invalid.

Comment 6

10 years ago
As the .ics, so the bug.

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.