dragover state persists on container bookmark-item after drag operation is finished

RESOLVED DUPLICATE of bug 467778

Status

()

--
minor
RESOLVED DUPLICATE of bug 467778
11 years ago
9 years ago

People

(Reporter: mcdavis941.bugs, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Under certain circumstances, when you drag a URI to an existing folder in the bookmarks toolbar, the dragover attribute stays on the container item even after the drag is complete.  It seems like the attribute should instead be removed after the operation is complete.

It's removed if you drag and drop directly onto the container item, but if you drag and drop onto the open menupopup, the attribute stays even after the operation completes.

STR: 
1. drag from favicon in location bar to existing folder item in bookmarks toolbar
2. hover but don't release over folder item, waiting for it to open and show the menupopup
3. drag down onto the open menupopup and release to add new bookmark in the container
4. the drag and drop is now done but the container element still has dragover="true"
Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
this WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 ID:2008070208

@reporter: if this works for you too, please close this bug as WFM - thanks.
any news?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467778
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.