dragged items in linux are not transparent, making impossible to see the target

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
a year ago

People

(Reporter: Marko.Macek, Unassigned)

Tracking

({polish})

Trunk
x86
Linux
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Version 3.0b4

When dragging bookmarks in the bookmarks editor (Library, Places?), the bookmarks are not transparent, so it's not easy to see where to drop them.
When dragging more than bookmark, it's basically impossible.

It would help if either
a) the image being drawn was at bottom;right of mouse cursor, not centered.
b) the transparency worked (and was not slow)
Component: Bookmarks → Places
QA Contact: bookmarks → places
Duplicate of this bug: 429769
Keywords: polish
Summary: linux bookmarks window drag drop transparency → dragged items in linux are not transparent, making impossible to see the target
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I just tried and looks like this is now WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 4

a year ago
I am seeing this issue on Firefox 57.0.1 (64-bit) running on LXDE on Fedora 57.

When I drag bookmarks in the bookmarks bar, the opaque background of the dragged item obscures everything underneath, including the caret that shows if/where it will be dropped. As a result it often takes several attempts to drag an item successfully, and sometimes it accidentally ends up dropped inside the wrong folder. This is a very visible and annoying issue.
You need to log in before you can comment on or make changes to this bug.