Closed Bug 422340 Opened 12 years ago Closed 11 years ago

Firefox 3 beta 4 gives unhelpful slowscript warning on leaving gmail

Categories

(Core :: XPConnect, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: alexandre, Assigned: timeless)

References

()

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

i get this crash everytime i leave gmail:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: XPCSafeJSObjectWrapper.cpp:446

NB: extensions installed: Remember The Milk for Gmail



Reproducible: Always

Steps to Reproduce:
1. go to gmail
2. click a few emails
3. close the browser
Actual Results:  
A message is displayed: 

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: XPCSafeJSObjectWrapper.cpp:446

Expected Results:  
no crash

This might be relevant: I have the "Remember The Milk for Gmail" extension installed.
Component: Startup and Profile System → XPConnect
Product: Firefox → Core
QA Contact: startup → xpconnect
Summary: Firefox 3 beta 4 crashes on leaving gmail → Firefox 3 beta 4 gives unhelpful slowscript warning don leaving gmail
Version: unspecified → Other Branch
Attached patch get line number from callers (obsolete) — Splinter Review
Assignee: nobody → timeless
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #308817 - Flags: review?(mrbkap)
if you want to help us chase the actual problem, you have 3 choices:

a. install venkman and use either the debugger (to stop at the problem) or the profiler (to just figure it out that way)
b. install firebug (and pray that you don't need chrome bug) and do essentially the same thing (many fewer guarantees)
c. install windbg and follow the approximate steps between 
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg
and the following additional notes:
when the dialog appears attach the debugger (file>attach to process), follow the steps in the how_to to setup the symbol path and get symbols, then use:

~* kp

to get a stack trace. copy the output from the command window to a file and "add an attachment" to this bug. eventually we'll need a second bug, because all I can fix from here is a hint as to which of a bunch of methods is slow.

eventually you'll be asked to get a js stack trace too (it's relatively easy to get one w/ venkman or firebug when they work, and I'll try to have a howto for windbg [it's not hard, merely a bit tedious, and should be converted into a macro])

Also, if you disable the extension, does the problem go away? (plus a complete list of extensions you have would be good, and as always, if you do use safemode, does the problem go away?)
Summary: Firefox 3 beta 4 gives unhelpful slowscript warning don leaving gmail → Firefox 3 beta 4 gives unhelpful slowscript warning on leaving gmail
Version: Other Branch → Trunk
hi,

I have two extensions in my FF 3beta 4 installation: Prism and Remember The Milk for Gmail. ("RTM")

I disabled RTM and the bug disappeared. So i suppose that the extension is the culprit !

Do you still want me to take the suggested steps ? ( i was going to install windbg)
yes please, but use a new bug (firefox:extension compatibility) to report the outcome. just comment w/ the bug number here after you file it.
hi there,

here it is: Bug 422373

thank you !
Duplicate of this bug: 422782
(In reply to comment #4)
> yes please, but use a new bug (firefox:extension compatibility) to report the
> outcome. just comment w/ the bug number here after you file it.

Is there anything left for this bug report then since bug 422373 is already filed?
Duplicate of this bug: 438516
Duplicate of this bug: 435349
Duplicate of this bug: 422373
Comment on attachment 308817 [details] [diff] [review]
get line number from callers

>Index: XPCSafeJSObjectWrapper.cpp
>+#define GetScriptedFunction GetScriptedFunction_P
> static JSBool
> GetScriptedFunction(JSContext *cx, JSObject *obj, JSObject *unsafeObj,

Instead of the crazy #define jazz, just rename the function.

r=mrbkap with that fixed.
Attachment #308817 - Flags: review?(mrbkap) → review+
Attached patch less magic (obsolete) — Splinter Review
mrbkap: i hope you understand that this has always required /some/ magic.

if this magic is acceptable, mark r+, and it'll eventually end up in the tree.
Attachment #308817 - Attachment is obsolete: true
Attachment #355329 - Flags: review?(mrbkap)
Attachment #355329 - Flags: superreview+
Attachment #355329 - Flags: review?(mrbkap)
Attachment #355329 - Flags: review+
Comment on attachment 355329 [details] [diff] [review]
less magic

r+sr=mrbkap -- please add a comment above the function to remind people to change the macro parameter list when the change the function's parameter list.
Attached patch for checkinSplinter Review
Attachment #355329 - Attachment is obsolete: true
Attachment #356353 - Flags: superreview+
Attachment #356353 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/9d84b77306db
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.