Remember The Milk For Gmail Extension causes beta 4 to crash on exit

RESOLVED DUPLICATE of bug 422340

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 422340
10 years ago
10 years ago

People

(Reporter: Alexandre Plennevaux, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

i get this crash everytime i leave gmail:

A script on this page may be busy, or it may have stopped responding. You can
stop the script now, or you can continue to see if the script will complete.

Script: XPCSafeJSObjectWrapper.cpp:446

NB: extensions installed: Remember The Milk for Gmail


Reproducible: Always

Steps to Reproduce:
1. go to gmail
2. click a few emails
3. close the browser

Actual Results:  
A message is displayed: 

A script on this page may be busy, or it may have stopped responding. You can
stop the script now, or you can continue to see if the script will complete.

Script: XPCSafeJSObjectWrapper.cpp:446


Expected Results:  
no crash

First reported in bug 422340 (https://bugzilla.mozilla.org/show_bug.cgi?id=422340), The extension has been identified.
(Reporter)

Comment 1

10 years ago
Created attachment 308843 [details]
Stack Trace done via windbg

Comment 2

10 years ago
hrm, odd are you attaching or running? if you're running, you'll need to check "debug child processes also".
(Reporter)

Comment 3

10 years ago
Created attachment 308871 [details]
Stack Trace done via windbg (second try)

i think this one has the Access Violation message.

Comment 4

10 years ago
yeah, that's better. please follow the instructions from the url to use .sympath...;.symfix...;.reload... and !analyze -v
(Reporter)

Comment 5

10 years ago
i didn't see any instructions like sympath, etc. (i'm just a web developer :( ) but maybe the folks developing the RTM extension will be able to be of more help.

here is another try, with kp

CommandLine: "C:\Program Files\Mozilla Firefox 3 Beta 3\firefox.exe"  -P FF3 -no-remote
Starting directory: C:\Program Files\Mozilla Firefox 3 Beta 3
Symbol search path is: SRV*c:\symbols*http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
ModLoad: 00400000 0044b000   firefox.exe
ModLoad: 7c910000 7c9c7000   ntdll.dll
ModLoad: 7c800000 7c905000   C:\WINDOWS\system32\kernel32.dll
ModLoad: 604b0000 60de3000   C:\Program Files\Mozilla Firefox 3 Beta 3\xul.dll
ModLoad: 60230000 60297000   C:\Program Files\Mozilla Firefox 3 Beta 3\sqlite3.dll
ModLoad: 60000000 600ad000   C:\Program Files\Mozilla Firefox 3 Beta 3\MOZCRT19.dll
ModLoad: 77be0000 77c38000   C:\WINDOWS\system32\msvcrt.dll
ModLoad: 60100000 601ac000   C:\Program Files\Mozilla Firefox 3 Beta 3\js3250.dll
ModLoad: 600b0000 600e0000   C:\Program Files\Mozilla Firefox 3 Beta 3\nspr4.dll
ModLoad: 77da0000 77e4c000   C:\WINDOWS\system32\ADVAPI32.dll
ModLoad: 77e50000 77ee1000   C:\WINDOWS\system32\RPCRT4.dll
ModLoad: 71a10000 71a1a000   C:\WINDOWS\system32\WSOCK32.dll
ModLoad: 719f0000 71a07000   C:\WINDOWS\system32\WS2_32.dll
ModLoad: 719e0000 719e8000   C:\WINDOWS\system32\WS2HELP.dll
ModLoad: 76ae0000 76b0f000   C:\WINDOWS\system32\WINMM.dll
ModLoad: 7e390000 7e420000   C:\WINDOWS\system32\USER32.dll
ModLoad: 77ef0000 77f37000   C:\WINDOWS\system32\GDI32.dll
ModLoad: 60450000 60468000   C:\Program Files\Mozilla Firefox 3 Beta 3\smime3.dll
ModLoad: 60360000 60407000   C:\Program Files\Mozilla Firefox 3 Beta 3\nss3.dll
ModLoad: 60410000 60424000   C:\Program Files\Mozilla Firefox 3 Beta 3\nssutil3.dll
ModLoad: 600f0000 600f7000   C:\Program Files\Mozilla Firefox 3 Beta 3\plc4.dll
ModLoad: 600e0000 600e7000   C:\Program Files\Mozilla Firefox 3 Beta 3\plds4.dll
ModLoad: 60430000 6044e000   C:\Program Files\Mozilla Firefox 3 Beta 3\ssl3.dll
ModLoad: 7c9d0000 7d1f5000   C:\WINDOWS\system32\SHELL32.dll
ModLoad: 77f60000 77fd6000   C:\WINDOWS\system32\SHLWAPI.dll
ModLoad: 774a0000 775dd000   C:\WINDOWS\system32\ole32.dll
ModLoad: 77bd0000 77bd8000   C:\WINDOWS\system32\VERSION.dll
ModLoad: 72f50000 72f76000   C:\WINDOWS\system32\WINSPOOL.DRV
ModLoad: 76340000 7638a000   C:\WINDOWS\system32\COMDLG32.dll
ModLoad: 77390000 77493000   C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2982_x-ww_ac3f9c03\COMCTL32.dll
ModLoad: 76320000 7633d000   C:\WINDOWS\system32\IMM32.dll
ModLoad: 76310000 76315000   C:\WINDOWS\system32\MSIMG32.dll
ModLoad: 753c0000 7542b000   C:\WINDOWS\system32\USP10.dll
ModLoad: 770e0000 7716b000   C:\WINDOWS\system32\OLEAUT32.dll
ModLoad: 60df0000 60df7000   C:\Program Files\Mozilla Firefox 3 Beta 3\xpcom.dll
(1bd4.2768): Break instruction exception - code 80000003 (first chance)
eax=00191eb4 ebx=7ffd9000 ecx=00000005 edx=00000020 esi=00191f48 edi=00191eb4
eip=7c911230 esp=0012fb20 ebp=0012fc94 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000202
ntdll!DbgBreakPoint:
7c911230 cc              int     3
0:000> g
ModLoad: 62dc0000 62dc9000   C:\WINDOWS\system32\LPK.DLL
ModLoad: 48000000 4801f000   C:\PROGRA~1\Google\GOOGLE~1\GOEC62~1.DLL
ModLoad: 62000000 6208e000   C:\PROGRA~1\Google\GOOGLE~1\GoogleDesktopResources_fr.dll
ModLoad: 71990000 719d0000   C:\WINDOWS\system32\mswsock.dll
ModLoad: 5d3f0000 5d491000   C:\WINDOWS\system32\dbghelp.dll
ModLoad: 74690000 746db000   C:\WINDOWS\system32\MSCTF.dll
ModLoad: 778e0000 779d8000   C:\WINDOWS\system32\SETUPAPI.dll
ModLoad: 76f80000 76fff000   C:\WINDOWS\system32\CLBCATQ.DLL
ModLoad: 77000000 770d4000   C:\WINDOWS\system32\COMRes.dll
ModLoad: 601b0000 601c4000   C:\Program Files\Mozilla Firefox 3 Beta 3\components\browserdirprovider.dll
ModLoad: 62e40000 62e99000   C:\WINDOWS\system32\hnetcfg.dll
ModLoad: 719d0000 719d8000   C:\WINDOWS\System32\wshtcpip.dll
ModLoad: 76d10000 76d29000   C:\WINDOWS\system32\iphlpapi.dll
ModLoad: 75140000 7516e000   C:\WINDOWS\system32\msctfime.ime
ModLoad: 5b090000 5b0c8000   C:\WINDOWS\system32\uxtheme.dll
ModLoad: 76ed0000 76ef7000   C:\WINDOWS\system32\DNSAPI.dll
ModLoad: 76f60000 76f68000   C:\WINDOWS\System32\winrnr.dll
ModLoad: 76f10000 76f3d000   C:\WINDOWS\system32\WLDAP32.dll
ModLoad: 16080000 16099000   C:\Program Files\Bonjour\mdnsNSP.dll
ModLoad: 10000000 10019000   C:\Documents and Settings\Alexandre Plennevaux\Application Data\Mozilla\Firefox\Profiles\Nouveau dossier\extensions\refractor@developer.mozilla.org\components\prism.dll
ModLoad: 20000000 202da000   C:\WINDOWS\system32\xpsp2res.dll
ModLoad: 60310000 60334000   C:\Program Files\Mozilla Firefox 3 Beta 3\softokn3.dll
ModLoad: 60340000 60358000   C:\Program Files\Mozilla Firefox 3 Beta 3\nssdbm3.dll
ModLoad: 60470000 604a9000   C:\Program Files\Mozilla Firefox 3 Beta 3\freebl3.dll
ModLoad: 602c0000 60304000   C:\Program Files\Mozilla Firefox 3 Beta 3\nssckbi.dll
ModLoad: 601d0000 6020c000   C:\Program Files\Mozilla Firefox 3 Beta 3\components\brwsrcmp.dll
ModLoad: 010f0000 01103000   C:\WINDOWS\system32\btmmhook.dll
BTMMHOOK 12.03.2008 17:57:35 Thread<2768> Hook DLL loaded
ModLoad: 011f0000 011f8000   C:\Acer\Empowering Technology\ePower\SysHook.dll
ModLoad: 73d20000 73e1e000   C:\WINDOWS\system32\MFC42.DLL
ModLoad: 61d70000 61d7e000   C:\WINDOWS\system32\MFC42LOC.DLL
ModLoad: 76f70000 76f76000   C:\WINDOWS\system32\rasadhlp.dll
ModLoad: 77760000 778d0000   C:\WINDOWS\system32\shdocvw.dll
ModLoad: 779e0000 77a76000   C:\WINDOWS\system32\CRYPT32.dll
ModLoad: 77a80000 77a92000   C:\WINDOWS\system32\MSASN1.dll
ModLoad: 76610000 76694000   C:\WINDOWS\system32\CRYPTUI.dll
ModLoad: 76be0000 76c0e000   C:\WINDOWS\system32\WINTRUST.dll
ModLoad: 76c40000 76c68000   C:\WINDOWS\system32\IMAGEHLP.dll
ModLoad: 6fee0000 6ff34000   C:\WINDOWS\system32\NETAPI32.dll
ModLoad: 7f400000 7f4d0000   C:\WINDOWS\system32\WININET.dll
ModLoad: 02dc0000 02dc9000   C:\WINDOWS\system32\Normaliz.dll
ModLoad: 7f560000 7f68e000   C:\WINDOWS\system32\urlmon.dll
ModLoad: 5dca0000 5dce5000   C:\WINDOWS\system32\iertutil.dll
ModLoad: 77270000 77296000   C:\WINDOWS\system32\IESetting.dll
ModLoad: 74da0000 74e0c000   C:\WINDOWS\system32\RichEd20.dll
ModLoad: 42000000 42035000   C:\PROGRA~1\Google\GOOGLE~1\GoogleDesktopCommon.dll
ModLoad: 30000000 30395000   C:\WINDOWS\system32\Macromed\Flash\NPSWF32.dll
ModLoad: 75d30000 75dc1000   C:\WINDOWS\system32\mlang.dll
ModLoad: 72c70000 72c79000   C:\WINDOWS\system32\wdmaud.drv
ModLoad: 72c60000 72c68000   C:\WINDOWS\system32\msacm32.drv
ModLoad: 77bb0000 77bc5000   C:\WINDOWS\system32\MSACM32.dll
ModLoad: 77ba0000 77ba7000   C:\WINDOWS\system32\midimap.dll
ModLoad: 027e0000 027f1000   C:\WINDOWS\system32\Secur32.dll
ModLoad: 76790000 767b7000   C:\WINDOWS\system32\schannel.dll
ModLoad: 76960000 76a15000   C:\WINDOWS\system32\USERENV.dll
(1bd4.1b94): Break instruction exception - code 80000003 (first chance)
eax=7ffd9000 ebx=00000001 ecx=00000002 edx=00000003 esi=00000004 edi=00000005
eip=7c911230 esp=011effcc ebp=011efff4 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00000246
ntdll!DbgBreakPoint:
7c911230 cc              int     3
0:015> kp
ChildEBP RetAddr  
011effc8 7c9607a8 ntdll!DbgBreakPoint
011efff4 00000000 ntdll!DbgUiRemoteBreakin+0x2d
0:015> g
BTMMHOOK 12.03.2008 18:00:36 Thread<2768> Hook DLL unloaded
eax=77c0b8c1 ebx=00000000 ecx=002723d8 edx=77c31ae8 esi=7c91e88e edi=00000000
eip=7c91eb94 esp=0012fe24 ebp=0012ff20 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246
ntdll!KiFastSystemCallRet:
7c91eb94 c3              ret
0:000> kp
ChildEBP RetAddr  
0012fe20 7c91e89a ntdll!KiFastSystemCallRet
0012fe24 7c81cd96 ntdll!ZwTerminateProcess+0xc
0012ff20 7c81cdee kernel32!_ExitProcess+0x62
0012ff34 6000179e kernel32!ExitProcess+0x14
0012ff40 60001b66 MOZCRT19!__crtExitProcess(int status = 1610619886)+0x2e [e:\fx19rel\winnt_5.2_depend\mozilla\obj-fx-trunk\memory\jemalloc\src\crt0dat.c @ 683]
0012ff78 60001bee MOZCRT19!doexit(int code = 0, int quick = 0, int retcaller = 0)+0x116 [e:\fx19rel\winnt_5.2_depend\mozilla\obj-fx-trunk\memory\jemalloc\src\crt0dat.c @ 596]
0012ff88 00401439 MOZCRT19!exit(int code = 2088857559)+0xe [e:\fx19rel\winnt_5.2_depend\mozilla\obj-fx-trunk\memory\jemalloc\src\crt0dat.c @ 398]
0012ffc0 7c816fd7 firefox!__tmainCRTStartup(void)+0x169 [e:\fx19rel\winnt_5.2_depend\mozilla\obj-fx-trunk\memory\jemalloc\src\crtexe.c @ 605]
0012fff0 00000000 kernel32!BaseProcessStart+0x23

Comment 6

10 years ago
sorry about sympath, i didn't read carefully, your sympath was already set (but please stick to attachments), so that's ok.

but i suspect you lost the debug child processes also bit :(.

when you actually get the access violation again, try this sequence:
!analyze -v
~
~* kp

I suspect that ~ alone will be unhappy if things are really bad, but i'm not sure.

Comment 7

10 years ago
Relevant discussion, including developers of the extension: http://www.rememberthemilk.com/forums/help/4032.

What's interesting is that I haven't received this issue since RTM's updated extension (March 14th). Is this still an issue?

Comment 8

10 years ago
Probably a duplicate of bug 422340.
See also Bug 422782
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Duplicate of bug: 422340
You need to log in before you can comment on or make changes to this bug.