Closed Bug 422412 Opened 12 years ago Closed 12 years ago

Accepting a iMip/iTip invitation into a WCAP calendar doesn't work

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

References

Details

Attachments

(1 file)

===================

- add a WCAP calendar to your calendar list
- open a e-Mail with an iMip/iTip invitation
- push the 'Accept' button
- choose the WCAP calendar in the 'choose calendar' dialog
- push the 'OK' button
- check your calendar view

RESULT:
=======

- the event is not added to your WCAP calendar

EXPECTED RESULT:
================

- the event should be visible in your WCAP calendar

REPRODUCIBLE:
=============

- always

Same with a local storage calendar or a calDAV calendar works.
Flags: blocking-calendar0.8?
Flags: blocking-calendar0.8? → blocking-calendar0.8+
What Lightning build did you used for testing? Bug 421909 covered the same issue but was resolved as duplicate of Bug 419817 that was just fixed yesterday.

Any messages in the Error Console?
taking care of this one
Assignee: nobody → daniel.boelzle
There are no error messages in the error console. I used lightning 2008031118 but today I will check this issue again with the newest build.
This bug is also reproducible with the latest lightning build 2008031219.
Duplicate of this bug: 421909
Attached patch fixSplinter Review
- WCAP reports a different error than just NS_ERROR_FAILED, so I switch the logic to test against != NS_OK.
- two more flaws in WCAP discovered and fixed
Attachment #309362 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Comment on attachment 309362 [details] [diff] [review]
fix


>-                if (aStatus == Components.results.NS_ERROR_FAILURE &&
>+                if (aStatus != Components.results.NS_OK &&
I'd prefer if (!Components.isSuccessCode(aStatus))

r=philipp
Attachment #309362 - Flags: review?(philipp) → review+
Checked in on HEAD, MOZILLA_1_8_BRANCH and SUNBIRD_0_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Component: Provider: WCAP → E-mail based Scheduling (iTIP/iMIP)
QA Contact: wcap-provider → email-scheduling
Checked in nightly build 2008031704 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 423468
You need to log in before you can comment on or make changes to this bug.