J and K hotkeys in Google Reader stop working after a link is opened in another tab

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Wes Bigelow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

While using Google Reader, if I click on a link with the middle mouse button to open it in a new tab (without switching focus to that tab), the J and K hotkeys stop working to browse up and down new items, until the original Google Reader window is left clicked on (even though it never lost focus).  This used to work correctly in Firefox 2.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.google.com/reader/view and view some feeds.
2. Press J to jump to the next item.  
3. Middle click any link to open it in a new tab.
4. Now press J again to jump to the next item.
Actual Results:  
Even though the Google Reader window never lost focus, the J key will no longer jump to the next item (until the Google Reader window is left clicked again.)

Expected Results:  
The J and K hotkeys should continue to work while the user is viewing Google Reader.

Comment 1

10 years ago
I have the same problem under Mac OS X 10.5.2.

http://groups.google.com/group/google-reader-troubleshoot/browse_thread/thread/9a2125927cc0ceb6?hl=en

This seemed to happen in various browsers (Firefox 2, Camino) and it looks like they have fixed it atleast for Firefox 2, although I still see this problem on Firefox nightlies.

Comment 2

10 years ago
I can confirm this behaviour in Google Reader and other google applications (eg gmail) on both Windows XP and Mac OS X Tiger. It occurs when a new tab is opened in the background, and the current tab always loses focus for keyboard input.

The behaviour was good for Firefox 3 Beta 2, but was wrong by Beta 4 (not sure about Beta 3).

This is a serious loss of functionality, and is sufficient to cause me to downgrade to an earlier beta. I believe it is serious enough to block the release of Firefox 3, being a huge step-down in functionality for keyboard users. Since this functionality worked until a recent beta release, it should hopefully not be too difficult to fix for someone who knows the code.
Flags: blocking-firefox3?

Comment 3

10 years ago
Actually it seems to work for me now. I can't say exactly when the problem went away but it must be within the last couple of days. A post from April 2nd in thread linked in comment #1 above mentions a "fix in a couple of days"...
WFM.  Please file a new bug if this breaks again, but it looks like a bug on the server side.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.