All occurances of recurring tasks are marked completed if checked on Events and Tasks window.

RESOLVED DUPLICATE of bug 373775

Status

Calendar
Tasks
--
major
RESOLVED DUPLICATE of bug 373775
11 years ago
11 years ago

People

(Reporter: John Tafelski, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; FDM)
Build Identifier: Lightening, Version 0.7

Recurring tasks that are checked off as completed or deleted in the Events and Tasks window, which appears alongside Thunderbird, cause all future occurances to also be changed.  This does not happen if the same recurring tasks are individually edited on the full screen calendar window, but those changes do not affect the corresponding tasks on the Events and Tasks window.  

Reproducible: Always

Steps to Reproduce:
1.Create a recurring task with Lightening, such as a weekly task to repeat every Monday.
2.Switching Thunderbird to Mail view and displaying Events and Tasks, check off the task as being completed, or simply delete it.

Actual Results:  
Changing to Calendar view, the Month view now shows the task as being marked completed on all future occurances. (Or not there at all, if it was deleted on the other window.)

Expected Results:  
Should only have affected the individual date that was marked complete or deleted, and future occurances should remain unaffected.  Would be solve the problem if the software asked if the change should affect only the current or all future occurances the same way it does when editing in the calendar view.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373775
You need to log in before you can comment on or make changes to this bug.