Table in fieldset renders wrong with display:inline or float

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Patrick Strasser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

A table in a fieldset, which is set to display:inline or float:left renders without aligning the cells horizontally. 

With display reseted to block, table rendering works, setting float to none will not restore correct rendering. 

As workaround, setting tableLayout="fixed" on the table with javascript will yield a aligned, but somtimes not correct dimensionized table.

This seems to be related to #129346, maybe a regrtession.

Reproducible: Always

Steps to Reproduce:
1. create a table in a fieldset.
2. set the fieldset to style display:inline or float:left
3. table will not align cells.
(Reporter)

Comment 1

10 years ago
Created attachment 308932 [details]
Demonstration of the bug with demo of workaround
Could you test this with the latest trunk nightly build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Could you test this with the latest trunk nightly build?
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Tested, bug did not occur.

Patrick
Then the bug will not be present anymore in Firefox 3. Thanks for testing this, Patrick. Resolving worksforme. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.