All users were logged out of Bugzilla on October 13th, 2018

Wrong rendering a dropdown controls in the Firefox 3 UI and webpages

RESOLVED INVALID

Status

()

P2
normal
RESOLVED INVALID
11 years ago
4 years ago

People

(Reporter: panchenko, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

The problem seems to be present only in Firefox 3.0, version 2.x not affected (tested in 2.0.0.12 and 3.0b4). I'm using a non-default custom Windows UI theme which has a .bmp image assigned for a combo box background. After switching to this windows theme Firefox starting to draw a big border around combobox controls which no border style on web pages. Same border present also on combobox controls on Firefox UI (like options form, etc.). Looks like Firefox 3.0 doesn't properly recognize a SizingMargins property of combobox from .msstyles file of current UI theme, because values of this property match a borer size around dropdown controls.

This problem apperas only in Firefox 3. All another application installed on my computer (including Firefox 2) has no problems displaying a combobox controls. If a select control on webpage has a border style attribute (or CSS class with border style) then it's displaying correctly.


Reproducible: Always

Steps to Reproduce:
1. In order to use custom themes or MSStyles on your computer you need to patch up your Uxtheme.dll file. 
2. Then download the theme from: http://www.customize.org/details/29471
extract the zip file anywhere, or if you like to follow windows dictation c:\windows\resources 
3. Double click on BW\BW.msstyles and switch to this theme.
4. Open Firefox 3 and navigate to any webpage with dropdown controls w/o border style or just open option window of Firefox.

Actual Results:  
Ugly borders (whitespace) around dropdown controls.

Expected Results:  
No whitespace, like in any other application.

This is a part of my current BW.msstyles related to dropdown controls
---
[Combobox]
BgType = ImageFile
ImageFile = Gloss\ListBackground.bmp
SizingMargins = 12, 12, 6, 6
SizingType = Stretch
BorderColor = 192 192 192
BorderSize = 1
FillColor = 255 255 255 
---
(Reporter)

Comment 1

11 years ago
Created attachment 308934 [details]
Screenshot describing a problem.

Please notice different rendering in 2.x and 3.0 versions.
(Reporter)

Comment 2

11 years ago
Created attachment 308935 [details]
Options form of Firefox3 - wrong rendering
(Reporter)

Comment 3

11 years ago
Created attachment 308936 [details]
Options form of Firefox2 - correct rendering

Comment 4

11 years ago
Can you reproduce this problem with a nightly build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ? If not, then this bug is a duplicate of bug 420580, otherwise a further regression from bug 418552.
Blocks: 418552
Keywords: regression
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> Can you reproduce this problem with a nightly build from
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ? If not,
> then this bug is a duplicate of bug 420580, otherwise a further regression from
> bug 418552.
> 

Just tryed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031205 Minefield/3.0b5pre.
Same problem, still exist.

Comment 6

11 years ago
Confirming per comment #5.

Vladimir: Any chance you could refactor the patch from bug 418552 to only apply to Vista and leave the old code path in there for XP?
Status: UNCONFIRMED → NEW
Component: OS Integration → Widget: Win32
Ever confirmed: true
Product: Firefox → Core
QA Contact: os.integration → win32
Version: unspecified → Trunk
Flags: blocking1.9?
Assignee: nobody → vladimir
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2

Updated

11 years ago
Blocks: 427122
No longer blocks: 427122
Depends on: 427122
Flags: wanted1.9.0.x+
Flags: blocking1.9-
Flags: blocking1.9+

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.