Closed Bug 422518 Opened 12 years ago Closed 12 years ago

Focus on browse history when typing keyword in URL ba

Categories

(Firefox :: Bookmarks & History, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 408723

People

(Reporter: glaroc, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3) Gecko/2008021408 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3) Gecko/2008021408 Firefox/3.0b3

When hitting ctrl-t to open a new tab and starting to type a keyword in the URL bar (not the search bar), the browse history expands, and the website that happens to be on focus in the browse history (depending on the mouse location) is used instead of the website corresponding to the keyword.  

Reproducible: Always

Steps to Reproduce:
For example, if the keyword "ff" corresponds to the firefox site bookmark:
1. Put cursor anywhere on the center and top portion of a page. 
2. Hit ctrl-t to open a new tab.
3. Type ff in the URL bar. 

Actual Results:  
The website on focus in the drop-down browse history will be loaded instead of the site corresponding to the keyword (the firefox website in this case). 

Expected Results:  
The site corresponding to the keyword should be loaded. 

This is something I do all the time, and there was no problems in previous versions.
Version: unspecified → Trunk
OS: Linux → All
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723
You need to log in before you can comment on or make changes to this bug.