History menu extends (entries multiplied and not between dividers)

VERIFIED FIXED in Firefox 3 beta5

Status

()

P2
major
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: volkmarkostka, Assigned: mak)

Tracking

({regression})

Trunk
Firefox 3 beta5
x86
All
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b5pre) Gecko/2008031205 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b5pre) Gecko/2008031205 Minefield/3.0b5pre

For several people sometimes the recent urls are not between the dividers. If this happens the items are added to the end of the menu. If you switch between History and e.g. Bookmarks the items are only every second time between the dividers. Once the items are added at the end they are not removed anymore extending the menu even more.

First time mentioned:
http://forums.mozillazine.org/viewtopic.php?p=3292186#3292186

Reproducible: Always

Steps to Reproduce:
1. Open the History menu
2. Close the History menu
3. Open the History menu again
Actual Results:  
Every second time the items are not between the markers but added to the end of the menu.

Expected Results:  
The items are inserted between the dividers every time.

Maybe a regression from bug #419544

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Version: unspecified → Trunk
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031205 Minefield/3.0b5pre ID:2008031205

Works: 20080311_2204_firefox-3.0b5pre.en-US.win32
Broken: 20080312_0515_N_firefox-3.0b5pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-03-11 22:04 and 2008-03-12 05:14 : 

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1205298240&maxdate=1205324099
Keywords: regression
(Assignee)

Comment 2

11 years ago
most likely a regression from my patch, due to some marker bug

should block
(Assignee)

Updated

11 years ago
OS: Windows 2000 → All
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Assignee: nobody → mak77
Status: ASSIGNED → NEW
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
(Assignee)

Updated

11 years ago
Duplicate of this bug: 422569
(Assignee)

Updated

11 years ago
Blocks: 419544
(Assignee)

Comment 4

11 years ago
Created attachment 309066 [details] [diff] [review]
patch

let's put this in before the next nightly
Attachment #309066 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Keywords: checkin-needed
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
mozilla/browser/components/places/content/menu.xml 1.120;
mozilla/browser/components/places/content/utils.js  1.121
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta5
Seems now that using 'History' and trying to open visits does nothing, and I see no errors in the console. 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008031314 Minefield/3.0b5pre Firefox/3.0 Firefox/2.0.0.12 ID:2008031314 <- Latest hourly
(Assignee)

Comment 8

11 years ago
(In reply to comment #7)
> Seems now that using 'History' and trying to open visits does nothing, and I
> see no errors in the console. 

That is Bug 422645, not related
Duplicate of this bug: 423485
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 422667
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.