Firefox leaks nsGlobalWindows with FoxieWire installed

NEW
Unassigned

Status

()

Core
General
9 years ago
9 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({mlk})

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9.0.x -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 309000 [details]
leak log

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031113 Firefox/3.0b5pre ID:2008031113

Steps to reproduce:
- Install the Nightly Tester Tool
- In the Preference of the NTT, disable the Add-on Compatibility check (because
FoxieWire is a Beta 4 Extension)
- Install FoxieWire
https://addons.mozilla.org/en-US/firefox/addon/6566
- Go into the Add-on Manager
- Make the Add-on Compatible to your Debug Build
- Restart Firefox to use this Extension (note: you might leak here because of bug 422542)
- Play a little with the Extension, use the preferences, have some tabs open and use as example on https://addons.mozilla.org/en-US/firefox/addon/6566 the right click context menu 
-> On the AMO Site i clicked twice "Submit this Page to FoxieWire 
-> Two additional tabs will open in this case
-> Close Firefox after this tabs are loaded
--> Leak

nsTraceRefcntImpl::DumpStatistics: 829 entries
nsStringStats
 => mAllocCount:          57534
 => mReallocCount:         7058
 => mFreeCount:           53762  --  LEAKED 3772 !!!
 => mShareCount:          60985
 => mAdoptCount:           4896
 => mAdoptFreeCount:       4894  --  LEAKED 2 !!!

   0 TOTAL                                          23   959531  2906486    34287 ( 3332.09 +/-  2622.95)  6953875    28111 ( 5330.81 +/-  7569.45)
Flags: blocking1.9?
Can you get this to leak more than two nsGlobalWindows, otherwise I don't think this is a blocker.
Leaks on installation, not a blocker.  Wanted 1.9.0.x.
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9-
Actually, tomcat will re-test this bug and re-nom if it's leaking more nsGlobalWindows.
This bug does not meet the new maintenance release (1.9.0.x) criteria (security, stability, regression from maintenance release).
Flags: wanted1.9.0.x+ → wanted1.9.0.x-
You need to log in before you can comment on or make changes to this bug.