Last Comment Bug 422566 - Firefox leaks during Installation of the Fast Weather Extension
: Firefox leaks during Installation of the Fast Weather Extension
Status: NEW
: mlk
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://addons.mozilla.org/en-US/fire...
Depends on: 421954
Blocks: 402335
  Show dependency treegraph
 
Reported: 2008-03-12 19:06 PDT by Carsten Book [:Tomcat] - PTO-back Sept 4th
Modified: 2008-10-28 15:58 PDT (History)
8 users (show)
dsicore: blocking1.9-
samuel.sidler+old: wanted1.9.0.x-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
leak log (27.22 KB, text/plain)
2008-03-12 19:06 PDT, Carsten Book [:Tomcat] - PTO-back Sept 4th
no flags Details

Description Carsten Book [:Tomcat] - PTO-back Sept 4th 2008-03-12 19:06:08 PDT
Created attachment 309017 [details]
leak log

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031113 Firefox/3.0b5pre ID:2008031113

Steps to reproduce:
- Install the Nightly Tester Tool
- In the Preference of the NTT, disable the Add-on Compatibility check (because
Fast Weather is a Beta 4 Extension)
- Install Fast Weather
https://addons.mozilla.org/en-US/firefox/addon/3344
- Go into the Add-on Manager
- Make the Add-on Compatible to your Debug Build

Possible another case of bug 421954 ?
- Restart Firefox to use this Extension
--> Leak

nsStringStats
 => mAllocCount:          42739
 => mReallocCount:         5716
 => mFreeCount:           42039  --  LEAKED 700 !!!
 => mShareCount:          39155
 => mAdoptCount:           3821
 => mAdoptFreeCount:       3819 

   0 TOTAL                                          28   250159  1053658     7746 ( 3634.85 +/-  3658.61)  2523483     4217 ( 3274.14 +/-  5480.73)
Comment 1 Damon Sicore (:damons) 2008-03-13 14:09:25 PDT
Not blocking.  Leaks only on installation.  Wanted 1.9.0.x.
Comment 2 Samuel Sidler (old account; do not CC) 2008-10-28 15:58:10 PDT
This bug does not meet the new maintenance release (1.9.0.x) criteria (security, stability, regression from maintenance release).

Note You need to log in before you can comment on or make changes to this bug.