bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Back+Forward on page with RealPlayer plugin makes it consume 100% CPU

RESOLVED WORKSFORME

Status

Plugins Graveyard
RealPlayer (Real)
--
major
RESOLVED WORKSFORME
11 years ago
2 years ago

People

(Reporter: mats, Unassigned)

Tracking

({regression})

Details

(Reporter)

Description

11 years ago
Back+Forward on page with RealPlayer plugin makes it consume 100% CPU.
Reloading the page fixes it.

STEPS TO REPRODUCE
1. load any page
2. load the attached testcase
3. click Back
4. click Forward

ACTUAL RESULTS
The area where the plugin is isn't repainted.
Windows Task Manager reports 50% CPU (I have a dual-core CPU so I suspect
this would be 100% CPU (and hang?) with a single-core CPU)
The Firefox UI is sluggish but working, clicking Reload fixes it.

PLATFORMS AND BUILDS TESTED
Bug occurs in Firefox trunk 2008031205 on Windows XPSP2
Bug occurs in Firefox 3.0b1 on Windows XPSP2

Updated

8 years ago
Component: Plug-ins → RealPlayer (Real)
Product: Core → Plugins
QA Contact: plugins → real-player
Version: Trunk → unspecified

Comment 1

2 years ago
It seams that RealPlayer plugin is not available for the latest versions of Firefox. I tested this test scenario using videos on Youtube that use Adobe Flash but didn't see the problem reported in this bug. Due to the above reasons and age of defect, I am going ahead and closing this bug. In case this is problem is seen again, please feel free to reopen this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.