Closed Bug 422579 Opened 13 years ago Closed 13 years ago

Highlighted text in forms blocks cursor movement with arrow keys

Categories

(Toolkit :: Find Toolbar, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 256989

People

(Reporter: jason_quinn, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4

Put some text in a form box. Do a find and highlight on some word in the text. Now try to move the cursor past that text (from left or right) using the arrow keys. The highlighted word blocks the cursor.

Reproducible: Always

Steps to Reproduce:
1. Put some text in a form box. 
2. Do a find and highlight on some word in the text. 
3. Try to move the cursor past that text (from left or right) using the arrow keys.
Actual Results:  
Cursor blocked.

Expected Results:  
Cursor should move right through highlighted text.

This problem exists in FF2 (all versions) in addition to the FF3b4 that I just tested.
I'd like to confirm this bug. I also have it with the April 1 Nightly Trunk of Minefield.

Highlighted text blocks in a text input form (works also with exactly the one I'm typing in right now) can't be passed by a cursor when moved with the arrow keys. The cursor stops in front of it and can only be moved in the opposite direction.

I used to reproduce:

1. Type in this textbox "Highlighted"
2. Press CTRL+F, then enter "gh" as the search text
3. Activate "Highlight all" in the Search Bar
4. Click behind the Word so the Cursor (shown as | ) is behind the word "Highlighted", making it look like: Highlighted|
5. Press "Left(Arrow)" on your Keyboard to move your cursor to the left.
6. You will notice you can't get it past the highlighted "gh" text, resulting in: Highligh|ted
Sorry for doubleposting, my exact Build didn't get automatically attached to the post:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040112 Minefield/3.0pre
confirmed: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008062603 Minefield/3.1a1pre 
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 256989
You need to log in before you can comment on or make changes to this bug.