DomI: doesn't blink when selecting an element to inspect.

RESOLVED DUPLICATE of bug 368608

Status

Other Applications
DOM Inspector
RESOLVED DUPLICATE of bug 368608
10 years ago
10 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
STR
1. open html element
2. open DomI to inspect page
3. select a DOM node in the left pane
Actual result: no blink around the element
Expected: a blinking (red) frame/border around the element.
The blinking frame makes it easy to see which DOM node is actually selected in complex layouts.

Applies to inspecting nodes in both contents and chrome.

This has been broken for quite a long time on trunk (Mac at least). I thought there was another bug on this, but can't find any.

Comment 1

10 years ago
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021202 SeaMonkey/2.0a1pre

Working on windows so must be platform specific.

(In reply to comment #1)
> Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre)
> Gecko/2008021202 SeaMonkey/2.0a1pre
> 
> Working on windows so must be platform specific.
> 

I'm seeing blinking rectangles on Linux (at least when the selected element is visible), so I concur that this bug must be platform-specific (unless it is INVALID, which would be the case if the reporter selected invisible items, but I don't think this was the case).

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031104 SeaMonkey/2.0a1pre
(Reporter)

Comment 3

10 years ago
So, probably Mac only.

I've already gone back as far as the Minefield 20061215 build, where this fails.

BTW - on an HTML doc that only contains one paragraph, there is little risk that the element is invisible - and usually the selected DOM node is scrolled into view anyway.

philippe: Let's be sure we're all testing the same thing - specifically, the same web page.  I'm assuming you're testing this on more than one page and seeing the same results - but just in case, can you give us a page where it's known to be broken?  Say, this bug report, or an attachment you provide?

(I'm playing devil's advocate here, I know.)

Also, is this with the milestone builds, with nightlies?  Did you compile these yourself, or did you grab them from tinderbox, ftp, etc.?  You didn't provide a user-agent build string.  (I'm personally thinking we might be missing a file in the installer that home-built builds have, which is why I ask - and that would be platform specific indeed.)

Updated

10 years ago
No longer blocks: 420105
Finding a "known good build" where it works and something very shortly afterwards doesn't would help a great deal, too - if you have the patience for it.  :-)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368608
You need to log in before you can comment on or make changes to this bug.