wrong textcontaining MATHML wrapping

RESOLVED DUPLICATE of bug 209693

Status

()

defect
RESOLVED DUPLICATE of bug 209693
11 years ago
10 years ago

People

(Reporter: olunet, Unassigned)

Tracking

({xhtml})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

according to http://www.w3.org/TR/html401/struct/text.html#h-9.3.5 text like <math><mi>x</mi></math> should not be wrapped after x. But it does not only in firefox, but also in other browsers. It is a error of text rendering.

Reproducible: Always

Steps to Reproduce:
1. make xml file
2. type <math><mi>x</mi><mi>y</mi><mi>z</mi></math>. several times in <p>
3. change body width
Actual Results:  
I've got
math
.
or
math
)

Expected Results:  
math.
math)
Reporter

Updated

11 years ago
Keywords: xhtml
Component: General → MathML
Product: Firefox → Core
QA Contact: general → mathml
Version: unspecified → Trunk
Reporter

Updated

11 years ago
Attachment #313898 - Attachment description: line-breaking of content in html + mathml → line-breaking of content in html + mathml, coment: most spaces are nbsp-character!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 313898 [details]
line-breaking of content in html + mathml, coment: most spaces are nbsp-character!

The approval1.9 flag is intended for reviewed patches.

blocking1.9 is the flag to request that something be fixed for 1.9.

While this behavior should be fixed, a blocking1.9 request would not be granted because this bug is not a regression.  Current priorities are to resolve regressions so that the improvements already made for 1.9 can be released.
Attachment #313898 - Flags: approval1.9?

Comment 3

10 years ago
This appears to be the same as bug #209693, and according to the discussion there it is still active in Firefox 3.5.3.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: linebreaksAroundMath
You need to log in before you can comment on or make changes to this bug.