Closed Bug 422645 Opened 14 years ago Closed 14 years ago

links in the history menu are not working

Categories

(Firefox :: Bookmarks & History, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta5

People

(Reporter: mak, Assigned: asaf)

References

Details

(Keywords: regression)

Attachments

(2 files)

seen on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031302 Minefield/3.0b5pre

all popups are working fine, aparte the extend bug in the history menu that should be fixed in the next build, if i click on an history item nothing happens, it's not visited, the onCommand is not fired.

need to find the regression window
Flags: blocking-firefox3?
Keywords: regression
if i'm not wrong this could be a regression from Bug 409748, if i put back the statustext attribute to the menuitems, the menu works again
Blocks: 409748
Assignee: nobody → mano
Priority: -- → P1
Target Milestone: --- → Firefox 3 beta5
I can confirm on WinXP
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031304 Minefield/3.0b5pre

What's worse is that clicking on a history link replicates the list.  Perform the bug 5 or 6 times to really see the problem.
Attached image History Replication
The history is replicated by this bug.
That bug is what Marco referred to in the first comment:
>the extend bug in the history menu that should be fixed in the next build

So those are two separate issues.  
This is All/All and major. 
Severity: normal → major
Hardware: PC → All
(In reply to comment #5)
> >the extend bug in the history menu that should be fixed in the next build
> 
> So those are two separate issues.  

exactly, that is bug 422528, these bugs are due to different things, even if they became visible in the same build.

Attached patch patchSplinter Review
Attachment #309301 - Flags: review?(dietrich)
Attachment #309301 - Flags: review?(dietrich) → review+
Attachment #309301 - Flags: approval1.9?
Flags: blocking-firefox3? → blocking-firefox3+
Attachment #309301 - Flags: approval1.9?
mozilla/browser/base/content/browser-menubar.inc 1.152
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: blocking-firefox3+ → blocking-firefox3?
Resolution: --- → FIXED
Duplicate of this bug: 422882
Flags: blocking-firefox3? → blocking-firefox3+
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 423649
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.