Unable to print when MOZILLA_POSTSCRIPT_PRINTER_LIST is set

RESOLVED DUPLICATE of bug 336170

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 336170
10 years ago
4 years ago

People

(Reporter: Karl Rossing, Unassigned)

Tracking

2.0 Branch
Other
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.1.12) Gecko/20080210 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.1.12) Gecko/20080210 Firefox/2.0.0.12

Tested with
ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.12/contrib/solaris_tarball/firefox-2.0.0.12.en-US.solaris10-sparc.tar.bz2
and
ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.12/contrib/solaris_tarball/firefox-2.0.0.12.en-US.solaris10-i386.tar.bz2

Unable to print when MOZILLA_POSTSCRIPT_PRINTER_LIST is set. Happens on sparc and i86pc versions.

FIX changed $FF_HOME/greprefs/all.js
from
pref("print.postscript.print_command", "lp -c -s ${MOZ_PRINTER_NAME:+'-d '}${MOZ_PRINTER_NAME}");
pref("print.print_command", "lp -c -s ${MOZ_PRINTER_NAME:+'-d '}${MOZ_PRINTER_NAME}");

to

pref("print.postscript.print_command", "lp -c -s ${MOZ_PRINTER_NAME:+'-d'}${MOZ_PRINTER_NAME}");
pref("print.print_command", "lp -c -s ${MOZ_PRINTER_NAME:+'-d'}${MOZ_PRINTER_NAME}");

When the space eg " " exists after the -d the lp returns unknown printer.

Reproducible: Always

Steps to Reproduce:

1. MOZILLA_POSTSCRIPT_PRINTER_LIST
2. start firefox from the command line
3. Print using PostScript/default, the job should print
4. Print using one of the printers in the list and the following is returned
<output>
 lj4: unknown printer
</output>
5. Print again using PostScript/default and the same error appears
<output>
 lj4: unknown printer
</output>
6. Restart Firefox and print using Postscript/Default and the job prints.
7. Close firefox and remove the space after -d in print.postscript.print_command and print.print_command in $FF_HOME/greprefs/all.js
8. Start Firefox and you are now able to print correctly using the printers listed in the print drop down menu.



Setting the print.print_command and print.postscript.print_command to use the full path eg: /usr/bin/lp did not fix the problem.


Did some command line testing and both of these prints worked ok.
lp -c -s -d lj4 /etc/hosts
lp -c -s -dlj4 /etc/hosts

So my question is why does it matter if there is a space after the -d in the  print.print_command or print.postscript.print_command?
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch
This is already fixed for Firefox 3. I just can't find the bug number currently..
Whiteboard: DUPEME

Comment 2

10 years ago
I couldn't reproduce it in firefox-3.0rc1.

Comment 3

10 years ago
This bug has been fixed in firefox 3. I marked this bug as a duplicate bug. We won't fixed in firefox 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 336170

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.