Browser displays HTML comments on the rendered page

VERIFIED DUPLICATE of bug 42270

Status

()

Core
HTML: Parser
P3
major
VERIFIED DUPLICATE of bug 42270
18 years ago
18 years ago

People

(Reporter: Stephan Niemz, Assigned: rickg)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
CVS checkout at Mon Jun 12 21:06:12 UTC 2000

    The browser displays Javascript code in http://bugzilla.mozilla.org/ (and
perhaps others) on the page itself, and renders the page completely wrong.
(Reporter)

Comment 1

18 years ago
Created attachment 9995 [details]
Sample screenshot showing this bug

Comment 2

18 years ago
I can't seem to duplicate this with the Bugzilla home page, but I can with
http://www.zdnet.com/eweek/stories/general/0,11011,2585114,00.html


Build 2000061214, Linux 2.2.14 i686, RedHat 6.1
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
sounds like 42270 to me

*** This bug has been marked as a duplicate of 42270 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
    Reopening, because bug 42270 is marked resolved/fixed, but I still get
this bug. Currently I'm seeing two incarnations:

1.
Start Mozilla and load http://bugzilla.mozilla.org/
At the top of the page I get:

The contents of this file are subject to the Mozilla Public License Version
1.1 (the "license"); you may not use this file except in compliance with
the license.

and so on, which is part of an HTML comment and shouldn't be displayed.
When loading this page a second time (e. g. by pressing the reload button),
the comment disappears.

2.
I'm going to attach an HTML file which should be rendered as an empty page
because it only contains comments in the body. Instead you see:

	form action="nothinguseful" method="post"

and so on. This time it doesn't disappear after reloading.

    My last CVS checkout was on 13.06.2000, 11:58 UTC. I have built a
non-debug and optimized Mozilla in an obj-* subdirectory, if that matters.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Browser displays Javascript code on the page → Browser displays HTML comments on the rendered page
(Reporter)

Comment 5

18 years ago
Created attachment 10046 [details]
Sample HTML file showing this bug

Comment 6

18 years ago
Pierre, please triage these from Clayton's list.
Assignee: clayton → pierre
Status: REOPENED → NEW
This is Rick's -- parser problem. Confirmed XP, I've seen this on Win32.
Component: Layout → Parser
OS: Linux → All
Hardware: PC → All

Comment 8

18 years ago
It could be a dup of bug 42340 except that it can be reproduced on all platforms.

Reassigned to rickg, CCd harishd.

Assignee: pierre → rickg
(Reporter)

Comment 9

18 years ago
    Yes, the description of bug 42340 is exactly what I've seen here and
described above - only on Linux, not on the Mac.

    Maybe the second part (the attached HTML file) is not the same bug, since
you don't have to restart the browser to get it again. I don't know. The
interesting thing is that if you remove a few lines of x-es in that file,
the bug disappears. It seams to depend on the huge amount of content (comment)
before that other comment which then gets displayed.

Comment 10

18 years ago
The problem was due to lack of error propagation [ refer to the patch in 
bug 42340 ], in CComment::Consume().
(Assignee)

Comment 11

18 years ago
Fixed in my tree.
Status: NEW → ASSIGNED
Whiteboard: fix in hand
(Assignee)

Comment 12

18 years ago
The bugzilla problem was related to a bug in the StrictDTD. This bughas to do 
with a bug in the parser. The bugzilla issue was resolved (42268) is fixed in my 
tree awaiting a chance to checkin.
(Assignee)

Comment 13

18 years ago

*** This bug has been marked as a duplicate of 42270 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 14

18 years ago
    I have tested it (after another checkout) with and without that patch
in bug 42270, and it fixes both issues for me. Thanks!
(Reporter)

Comment 15

18 years ago
Sorry, I meant the patch attached to bug 42340. It's here:

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=10156

Comment 16

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.