Invalid declarations within at-rules should be ignored while the valid ones are applied.

RESOLVED DUPLICATE of bug 431948

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 431948
10 years ago
10 years ago

People

(Reporter: Gauthier Van Vreckem, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

        <style type="text/css">
            body
            {
                color: red;
            }
            @media screen
            {
                p
                {
                    color: green;
                }
                p&div
                {
                    red: isbad /*this decl is bad but should not make the whole @media block bad*/
                }; 
            }
        </style>

    <body>
        <p>This text should be green.</p>
    </body>

Well, it is red...

Reproducible: Always

Comment 1

10 years ago
I guess you saw David's response if you're going to file bugs against failures with the Microsoft test suite?

http://lists.w3.org/Archives/Public/public-css-testsuite/2008Mar/0002.html

Regarding this one: "we fail Chapter_4/invalid-decl-at-rule-001.htm (not sure why yet)"

Comment 2

10 years ago
This is a DUPLICATE of bug 431948. Same URL. Same description. Resolving accordingly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 431948
You need to log in before you can comment on or make changes to this bug.