Dragging a favicon onto the Bookmarks-menu doesn't close the menu anymore

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
11 years ago
6 years ago

People

(Reporter: ria.klaassen, Unassigned)

Tracking

(Blocks: 1 bug, {regression, uiwanted})

Trunk
regression, uiwanted
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

STR:

- Drag the locationbar favicon onto the Bookmarks item in the menubar
- Release it

Expected behaviour: the bookmarks-menu should open and close, like in Firefox 2
Actual behaviour: the bookmarks-menu stays open

This does not happen when you drag it onto a folder on the Bookmarks Toolbar (and release it); this behaviour is still unchanged.

Regression window is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1204519140&maxdate=1204524539
-> bug 418156.
Flags: blocking-firefox3?
This will not block the final release of Firefox 3.
Flags: blocking-firefox3? → blocking-firefox3-
(Reporter)

Updated

11 years ago
Duplicate of this bug: 424129
(Reporter)

Updated

11 years ago
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Updated

11 years ago
Blocks: 424129
(Reporter)

Updated

11 years ago
Depends on: 430551

Comment 3

10 years ago
actually i'm not sure this is wanted, maintaining the menu open allow for better reorganization and we are trying to maintain open other menupopups too.
i've tried restoring the old behaviour but i feel it worst then the new, so waiting on ux team decisions
Keywords: uiwanted
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
we close the menu when dragging out of a menu, but never when dragging into it, this is coherent afaict.
I don't think we want to change this, we didn't really get much negative feedback about the current behavior (if we got any negative feedback at all).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.