[regression] Page with background-image: context-menu item 'View Background Image' greyed out

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Dwyane, Unassigned)

Tracking

({regression})

3.5 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

When on any webpage and I right click over the background and choose the option to "view background image", nothing happens. I would like to save the background image. 

Reproducible: Always

Steps to Reproduce:
1.Go to any webpage.
2.Place pointer over background and 'right click'
3.Choose "view background image"
Actual Results:  
Nothing happens. Unable to save background image.

Expected Results:  
The background image should have appeared with the background image url in the address bar.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031402 Minefield/3.0b5pre

This works fine here. Did you try:

- Firefox's safe-mode to exclude extension/theme problems
- a new profile
- a reinstall in a new empty folder?

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder

Comment 2

8 years ago
Works for me - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090319 Shiretoko/3.5b4pre

Comment 3

8 years ago
Fails with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090320 Minefield/3.6a1pre

Tested in -safe-mode
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Updated

8 years ago
Duplicate of this bug: 482941

Comment 5

8 years ago
But the context menu item works in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090320 Shiretoko/3.5b4pre
Summary: "view background image" doesn't work. → [regression] Page with background-image: context-menu item 'View Background Image' greyed out

Comment 6

8 years ago
Regression window in https://bugzilla.mozilla.org/show_bug.cgi?id=482941#c1

[quote]
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d9d4bf676f65&tochange=35d78a340566

Possibly bug 322475 ? (in which case, this probably should be a core bug)
[/quote]
Keywords: regression

Comment 7

8 years ago
Basically |(this.target instanceof HTMLHtmlElement| returns false.

      else if (this.target instanceof HTMLHtmlElement) {
        var bodyElt = this.target.ownerDocument.body;
        if (bodyElt) {
          var computedURL = this.getComputedURL(bodyElt, "background-image");
          if (computedURL) {
            this.hasBGImage = true;
            this.bgImageURL = makeURLAbsolute(bodyElt.baseURI,
                                              computedURL);
          }
        }
      }
Sounds like this was worksforme until the regression covered by bug 482941, so marking as such.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 9

8 years ago
How the heck is this WFM?

It still fails.  Try on this link: http://www.mozilla.com/en-US/

Updated

8 years ago
Version: Trunk → 3.1 Branch
IU, try reading the bug (and in particular comment 8).
You need to log in before you can comment on or make changes to this bug.