In table cell, overflow: auto, scroll and hidden doesn't clip the content of very wide element.

RESOLVED DUPLICATE of bug 409736

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 409736
11 years ago
10 years ago

People

(Reporter: KENZ (Kenji Irie), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9b5pre) Gecko/2008031318 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9b5pre) Gecko/2008031318 Minefield/3.0b5pre

In table cell, overflow: auto, scroll and hidden doesn't clip the content of very wide element.
Firefox 2 clips the content and shrinks the width of the very wide element.

Reproducible: Always

Steps to Reproduce:
1. see URL.
2. make your browser window narrow so that <pre> in table overflows.
Actual Results:  
<pre> with 'overflow: auto' doesn't show scrollbar, and it overlaps for the sidebar on the right side.

Expected Results:  
<pre> with 'overflow: auto' shoulde show scrollbar, and it doesn't overlap for sidebar on the right side.

Web browsers behave as Expected Results:
 * Firefox 2
 * Opera 9.5 beta (Build 9613)

Safari 3 public beta (3.0.4) and WebKit nightly does same layout with Firefox 3 trunk. So, this may be an intended behavior...
(Reporter)

Comment 1

11 years ago
Created attachment 309379 [details]
Simplified test case for reported problem.
(Reporter)

Comment 2

11 years ago
Reproducible on Mac or Linux.

Hardware->All
OS->All

Version->Trunk
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
This is the expected result of the change in bug 402567.  Are you sure your regression range isn't a day off?
(Reporter)

Comment 5

11 years ago
OK      Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9b2pre)
Gecko/2007120405 Minefield/3.0b2pre ID:2007120405
NG      Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9b2pre)
Gecko/2007120505 Minefield/3.0b2pre ID:2007120505

Bonsai range: 
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-12-04+05%3A00&maxdate=2007-12-05+05%3A00&cvsroot=%2Fcvsroot

I read a bit the bug 402567 (and see testcases with Opera...).
OK, I see why this changes.
If we can consider the width of (table or the cell's) containing block, can things be better? (Sorry, I'm not a expert of CSS 2.1 or CSS3 ...)

Updated

11 years ago
Duplicate of this bug: 423357
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409736
You need to log in before you can comment on or make changes to this bug.