If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Calendar
Provider: GData
RESOLVED DUPLICATE of bug 356002
10 years ago
10 years ago

People

(Reporter: Marc, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Lightning 0.7

The dismissing of reminder is impossible on my Ligntning version. Don't know why. Both individual reminders can't be deleted and Dismiss all doesn't work. I have added a screenshot of my reminders to help identify the configuration.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 309382 [details]
screenshot of the reminder screen with reminders
(Reporter)

Comment 2

10 years ago
Guys, this is a major issue. Am I wasting my time reporting this stuff? Please confirm or unconfirm

Comment 3

10 years ago
What type of calendar do you use? Local, CalDAV, WCAP, ICS, etc.? Do you have write access to the calendar? Do you see any error messages in the console when dismissing the events? Does the issue still exists using Lightning 0.8 RC1 or newer?
(Reporter)

Comment 4

10 years ago
Well, I'm not entirely sure where to find the about box for Lightning so I can tell you which version. Where is that?

Comment 5

10 years ago
Have a look at the add-ons manager (tools->Add-ons).

Comment 6

10 years ago
According to Comment #0 you are using Lightning 0.7 ;) 
Any further information regarding the questions from Comment #3?
(Reporter)

Comment 7

10 years ago
Ok, he's wrong. I have Lightning 0.8pre. With regards to type of calendar. I use Google Calendar for calendaring and have integrated with that.

Comment 8

10 years ago
What version of the Provider for Google Calendar extension do you use? 

This might be a duplicate of Bug 415742 that ought to be fixed in the latest nightly build of that extension.
Component: Alarms → Provider: GData
QA Contact: alarms → gdata-provider
(Reporter)

Comment 9

10 years ago
Well, I just use this URL to load my calendar content read only http://www.google.com/calendar/ical/<my account info>
(Reporter)

Comment 10

10 years ago
Created attachment 310476 [details]
My google calendar output to Lightning

Comment 11

10 years ago
Hello
I'm dropping in in the discussion. 

Maybe I have a similar problem: alarms on my READ ONLY remote or local) calendars cannot be dismissed, apparently, and produce errors when trying to. Is there a bug already filed for that?

Marc, is your calendar also set as read only in Lightning?
(Reporter)

Comment 12

10 years ago
The Google calendar is. Basically b/c My Google ical export is read only. The default calendar 'home' isn't. 

Comment 13

10 years ago
Please clarify: does this happens only with events from your read only google calendar? Or also with the local calendar mentioned in Comment #12?

You need write access to the calendar that contains the alarms to store the information that the alarm was dismissed. In this case it's a duplicate of Bug 356002.

Comment 14

10 years ago
So, I confirm that my comment #11 relates to bug 356002. 
(Reporter)

Comment 15

10 years ago
It happens with all events from the read only calendar. I'll turn read only off in Lightning and see what happens. Should be interesting, because my Google Calendar is still read only. Hmm, as expected. I can now dismiss but I get an error on syncing. I think I still get my calendar info in. So I should be ok. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

10 years ago
Darn, on every sync with the Google Calendar, it changes back the read only attribute to read only. Not ok, then.

Updated

10 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 356002

Comment 18

10 years ago
As written before your currently need write access to the calendar to dismiss/store alarms. Google Calendar allows write access only via the GDATA API but not via the ics feed. Write access to Google Calendar is possible e.g. by using the Provider for Google Calendar extension or GCALDaemon tool.
You need to log in before you can comment on or make changes to this bug.