Strangeness related to session restore and new windows

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: robertc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008031118 Minefield/3.0b4 (tete009 SSE2 PGO)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I think I ran across this problem just now using Firefox 3 Beta 4.  I had to
install some software, requiring an OS restart, but hadn't got round to reading
all the tabs I'd opened.  So I changed my prefs to 'windows and tabs from last
time', exited and restarted Windows.

When I started Firefox back up none of my tabs reappeared.  I didn't worry
about it overly at the time and just carried on working.  A couple of hours
later I tried to open up the Computer Weekly digital edition from this page:

http://redigitaleditions.com/activemagazine/welcome/cwe/cwe080311.asp

Normal behaviour (in Firefox 2) is that this link spawns a new browser window
with a single tab.  This time it spawned a new browser window with all my
windows and tabs from last time that hadn't appeared when starting the browser,
and then loaded the CW page on top of one of the existing tabs in this new
window.  I assume this is related to the window name in the window.open JS call
on the page above, but have no way of checking.

Similarly, I installed a new extension and selected restart.  Firefox claimed it was going to try and restore my windows and tabs, it didn't.  But I went to my delicious bookmarks (the web page), opened one in a new window through right click to see if those tabs would magically appear.  They didn't, but I did get two tabs in the new window, one of which was a popup window which I'd been looking at about 5 hours earlier on online.sainsburysbank.co.uk ('contact us help' popup).

Reproducible: Sometimes

Steps to Reproduce:
1. Close the browser with 'remember my windows and tabs from last time' enabled or restart because of add-on installation.
2. Restart browser and observe that windows and tabs are not restored.
3. Open a new window by right click or by clicking on a javascript:window.open link, find tabs you had open in your last session randomly appearing in the new windows.



Similar defects: 422189

Comment 1

11 years ago
Robert: Have you ever experienced this issue again? Even using Firefox 3.0 final and possibly disabling all incompatible extensions? If not, please close this bug as WORKSFORME.
(Reporter)

Comment 2

11 years ago
I did experience the problem again, on Ubuntu (Hardy BetaP5), and it seems to also mean your browser history is non-functional (couldn't re-open closed tabs, nothing ever appeared in the history menu).  I found that starting Firefox in safe mode, opening and closing a few tabs to verify history worked, then starting Firefox normally cleared the problem.  In both cases the profile involved had been created in 2.0 rather than a fresh one for 3.0.

However, not seen it since on several other upgrades, so will close as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.