Closed Bug 423040 Opened 13 years ago Closed 13 years ago

Cancel after adding a tag does not work

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 3 beta5

People

(Reporter: u286998, Assigned: dietrich)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031405 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031405 Minefield/3.0b5pre

more fallout from bug 384370 (s/Utils/UIUtils/):

Happens when you try to cancel after adding a tag to a bookmark.
Here is the error from the console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 

(NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.removeItem]"  nsresult:
"0x80070057 

(NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: 

file:///D:/Programme/Internet/firefox/components/nsPlacesTransactionsService.js
:: 

PTU_undoTransaction :: line 921"  data: no]

http://mxr.mozilla.org/firefox/source/browser/components/places/src/nsPlacesTransactionsService.js#921


Reproducible: Always
Blocks: 384370
Can you please provide the exact steps to reproduce this?
1. click the star (doesn't matter if the page is bookmarked or not)
2. add a new tag (by entering something in the text field or using the tag editor)
4. click cancel

observed behavior:
- if you click the star again you will see that the tags were added to the bookmark even though you canceled the process
- the error from comment 0 appears in the error console

expected behavior:
- the tags are not added
- no error in the error console

btw: canceling tag removal works without problems
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Firefox 3 beta5
Version: unspecified → Trunk
Attached patch fixSplinter Review
Assignee: nobody → dietrich
Status: NEW → ASSIGNED
Attachment #309691 - Flags: review?(mano)
Comment on attachment 309691 [details] [diff] [review]
fix

drivers: typo fix causing broken functionality
Attachment #309691 - Flags: approval1.9?
Comment on attachment 309691 [details] [diff] [review]
fix

a1.9=beltzner
Attachment #309691 - Flags: approval1.9? → approval1.9+
Duplicate of this bug: 423824
Checking in browser/components/places/src/nsPlacesTransactionsService.js;
/cvsroot/mozilla/browser/components/places/src/nsPlacesTransactionsService.js,v  <--  nsPlacesTransactionsService.js
new revision: 1.34; previous revision: 1.33
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.