Last Comment Bug 423060 - Feed Handling in Google/Yahoo/Bloglines broken
: Feed Handling in Google/Yahoo/Bloglines broken
Status: VERIFIED FIXED
: regression, relnote
Product: Firefox
Classification: Client Software
Component: RSS Discovery and Preview (show other bugs)
: Trunk
: All All
P2 normal (vote)
: Firefox 3
Assigned To: Robert Sayre
:
: Marco Bonardo [::mak]
Mentors:
: 423230 425180 432205 (view as bug list)
Depends on:
Blocks: 381357 469593
  Show dependency treegraph
 
Reported: 2008-03-14 18:18 PDT by Jaime Mitchell (use bugmail@jaimem.org.uk for email)
Modified: 2009-09-04 20:13 PDT (History)
15 users (show)
mconnor: blocking‑firefox3+
mozillamarcia.knous: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.19 KB, patch)
2008-03-20 17:14 PDT, Robert Sayre
no flags Details | Diff | Splinter Review
fix + test (5.03 KB, patch)
2008-03-31 15:15 PDT, Robert Sayre
gavin.sharp: review+
Details | Diff | Splinter Review

Description User image Jaime Mitchell (use bugmail@jaimem.org.uk for email) 2008-03-14 18:18:43 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008031405 Minefield/3.0b5pre ID:2008031405

STR:
1. New Profile
2. Go to a site with a feed such as http://news.bbc.co.uk
3. Click the RSS icon in the location bar
4. Select Google as the handler and use this as from now on/as default
5. Subscribe in google reader
6. Now go to another site with a feed such as http://www.theregister.co.uk
7. Select RSS icon

Result:
The site appears to refresh, nothing else seems to happen. No errors in the error console.

Expected:
Displays the google page which choice of subscribe in google reader or google home page

This is a reasonably recent regression, I will try and find the range over the weekend.
Comment 1 User image Marcia Knous [:marcia - use ni] 2008-03-14 18:57:22 PDT
Changing to all, I see this on Mac using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031404 Minefield/3.0b5pre as well as the Win XP nightly.
Comment 2 User image Phil Ringnalda (:philor) 2008-03-15 20:49:52 PDT
*** Bug 423230 has been marked as a duplicate of this bug. ***
Comment 3 User image Marcia Knous [:marcia - use ni] 2008-03-17 11:06:57 PDT
Regression window:  Works: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031104 Minefield/3.0b5pre

Broken: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031204 Minefield/3.0b5pre

Bug 381357 was the only bug I can see checked in related to RSS.
Comment 4 User image Marcia Knous [:marcia - use ni] 2008-03-17 11:20:19 PDT
https://litmus.mozilla.org/show_test.cgi?id=4304 has been added to Litmus.
Comment 5 User image Phil Ringnalda (:philor) 2008-03-17 11:29:46 PDT
Yeah, I wanted to blame sayrer, too, but backing bug 381357 out doesn't solve the
problem. Given the heinous things we do to channels and principals, now I'm
wondering about bug 415324.
Comment 6 User image Phil Ringnalda (:philor) 2008-03-17 16:26:53 PDT
Paging Mr. Sayre, Mr. Sayre to the Regression Penalty Box, please.

Dunno how I could have failed to back out such a simple patch, but I apparently did fail, since from the http://hourly-archive.localgho.st/ Windows builds, the first build with the problem is 20080311 14:05, and http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1205269500.1205274891.30404.gz&fulltext=1 says the changes that picked up included an OS2 readme change and bug 381357, so I'm back to betting on it.
Comment 7 User image Robert Sayre 2008-03-20 17:14:11 PDT
Created attachment 310875 [details] [diff] [review]
fix
Comment 8 User image Jaime Mitchell (use bugmail@jaimem.org.uk for email) 2008-03-24 11:39:21 PDT
This should be release noted for Beta 5.
Comment 9 User image Mike Beltzner [:beltzner, not reading bugmail] 2008-03-24 13:19:32 PDT
Rob: who should review this? Looks pretty small and simple, perhaps worth sneaking into B5 instead of relnote-ing.
Comment 10 User image Robert Sayre 2008-03-24 14:09:05 PDT
(In reply to comment #9)
> Rob: who should review this? Looks pretty small and simple, perhaps worth
> sneaking into B5 instead of relnote-ing.
> 

Anyone can review it once I finish the test.
Comment 11 User image Tony Chung [:tchung] 2008-03-24 14:12:12 PDT
hi rob, how close are you to completing the test?  i'd like to nom this for blocking beta 5 if you can get it done soon, and up for review.
Comment 12 User image Phil Ringnalda (:philor) 2008-03-26 08:21:13 PDT
*** Bug 425180 has been marked as a duplicate of this bug. ***
Comment 13 User image Robert Sayre 2008-03-31 15:15:35 PDT
Created attachment 312807 [details] [diff] [review]
fix + test
Comment 14 User image Marcia Knous [:marcia - use ni] 2008-04-01 12:47:59 PDT
verified fixed using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040104 Minefield/3.0pre as well as the nightly XP build. I verified using the STR in Comment 0.
Comment 15 User image Tanner M. Young [:tmyoung] 2009-09-04 20:13:32 PDT
*** Bug 432205 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.