Organize Bookmarks needs an ellipsis to convey that the action is not immediate

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: uliss, Assigned: philor)

Tracking

({late-l10n, user-doc-complete})

Trunk
late-l10n, user-doc-complete
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031404 Minefield/3.0b5pre

Show All Bookmarks menu item - opens a window - must have ellipsis
Show All Bookmarks opens a window titled Library - does not match the calling menu item
View _> Sidebar _> history results in a sidebar titled history not Library

Reproducible: Always

Steps to Reproduce:
1. visit 4 websites
2. in main menu select Bookmarks
3. in the pulldown menu select Show All Bookmarks - observe no ellipsis and title of window opened
4. in the main menu select view - navigate to Sidebar -> history
5. observe the title of the resultant sidebar matches the calling menu - History
Actual Results:  
1 history adds 4 sites
2 window titled library opens
3 sidebar titled History opens

Expected Results:  
1. missing ellipsis is a known bug in Safari on MAC OS X
2. Window must say history

Add ellipsis to menu item
change Library to history
The menu item is now a command instead of a window title (adjusting bug summary), but it needs an ellipsis.  From the all glorious HIG page 123:

[if the action] Is performed by the user in a separate window or dialog.

For example, Preferences, Customize Toolbar, and Send Feedback all use an ellipsis because they 
open a window (potentially in another application, such as a browser) or a dialog in which the 
user sets preferences, customizes the toolbar, or sends feedback. 
To see why such commands must include an ellipsis, consider that the absence of an ellipsis 
implies that the application performs the action for the user. If, for example, the Send Feedback 
command did not include an ellipsis, it would imply that feedback is generated and sent 
automatically by the application. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Summary: Show All Boomarks missing ellipsis and opens window titled library → Organize Bookmarks needs an ellipsis to convey that the action is not immediate
(Assignee)

Comment 2

11 years ago
And, because it's not just the One True HIG, from the Microsoft equivalent we have

[[[
Keep in mind that the decision about whether or not to use an ellipsis can depend on the context of the command. You must take into consideration the command's intended action, the wording of the command, or, for menu items, the wording of the command's parent menu item.
]]]

The bottom line is that an ellipsis should tell the user that it's safe to click the menu item, that the action won't be immediate. A sensible user *should* be afraid to click "Organize Bookmarks" without knowing what algorithm the program is going to use to organize his bookmarks, since he doesn't see any way to undo that organization and doesn't know whether or not he going to like it. "Show All Bookmarks" (which did have an ellipsis, but shouldn't have) is safe, it's just going to show them, but "Organize Bookmarks" sounds like it's going to happen without further input.
(Assignee)

Updated

11 years ago
Blocks: 421609
Component: Bookmarks → Places
QA Contact: bookmarks → places
Component: Places → Menus
OS: Mac OS X → All
QA Contact: places → menus
Hardware: Macintosh → All
Version: unspecified → Trunk
(Assignee)

Comment 3

11 years ago
Created attachment 309816 [details] [diff] [review]
Fix v.1
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #309816 - Flags: ui-review?(beltzner)
Attachment #309816 - Flags: review?(gavin.sharp)
Attachment #309816 - Flags: review?(gavin.sharp) → review+

Updated

11 years ago
Keywords: late-l10n
Comment on attachment 309816 [details] [diff] [review]
Fix v.1

We'll consider this for after code freeze.
Attachment #309816 - Flags: ui-review?(beltzner)
Attachment #309816 - Flags: ui-review+
Attachment #309816 - Flags: approval1.9?
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Comment on attachment 309816 [details] [diff] [review]
Fix v.1

a=beltzner
Attachment #309816 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 6

11 years ago
browser/base/content/browser-menubar.inc 1.157
browser/locales/en-US/chrome/browser/browser.dtd 1.105 
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Keywords: user-doc-needed

Updated

11 years ago
Keywords: user-doc-needed → user-doc-complete
You need to log in before you can comment on or make changes to this bug.