If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

images with percentage widths do not resize when browser window is resized

RESOLVED WORKSFORME

Status

()

Core
Layout: Images
RESOLVED WORKSFORME
10 years ago
a year ago

People

(Reporter: Beth, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b4) Gecko/2008031102 Minefield/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b4) Gecko/2008031102 Minefield/3.0b4

I am working on an image gallery where I am using percentage widths to display the images so that they will scale to appropriate sizes when the browser window is resized.  I have a div which is set to be 54% of the width of the page, and the image width is set to be 95% of that div.  The image is displayed at the right size when the page initially loads.  When the window is resized, the div grows or shrinks appropriately, but the images stays the same until the page is refreshed.  This works correctly in Opera and Konqueror.  Please see the below link for a minimal example:

http://narnia.homeunix.com/~stjohns/Pictures/testcase/pictures.html

Reproducible: Always

Steps to Reproduce:
1. Visit: http://narnia.homeunix.com/~stjohns/Pictures/testcase/pictures.html
2. Reduce the size of your browser window.
3.
Actual Results:  
Image stayed the same size, div shrunk, so that the image hangs out the right size of the div box.

Expected Results:  
Image should shrink with the window and the div.
(Reporter)

Comment 1

10 years ago
This works correctly on version 2.  The bug is only in firefox 3.
WFM with latest trunk build on Windows XP.
Component: General → Layout: Images
Product: Firefox → Core
QA Contact: general → layout.images
Version: unspecified → Trunk
(Reporter)

Comment 3

10 years ago
Seems to be working now, since I restarted my computer.

Comment 4

a year ago
I get expected results when using Firefox 47 stable release. Based on that and on Ria's and Beth's comments,

Resolving as WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.