Closed Bug 423080 Opened 13 years ago Closed 13 years ago

[Bookmark] cannot restore from backup (***.html) file

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX
Firefox 3

People

(Reporter: bugmozz, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031415 Minefield/3.0b5pre ID:2008031415

no problem from JSON file.
Severity: normal → major
Flags: blocking-firefox3?
Can you please provide a description of the problem, and steps to reproduce? If possible, provide the html or json file causing the problem.

Removing the blocking request until we figure out what the problem is.
Flags: blocking-firefox3?
backup file created by build before JSON is landed (ie:20080312 build...).

[step]
1) open Library
2) Import and Restore>Choose File
3) choose bookmark back file (bookmarks-200*-**-**.html/bookmarks.html/bookmarks.postplaces.html)


BTW can you restore bookmark from bookmarks-200*-**-**.html/bookmarks.html/bookmarks.postplaces.html ?
See bug 384370, comments #53 and #54 for background on the UI decisions. Here's a summary:

The Import/Export options are for the HTML format, for integration with external applications and publishing, and does not contain all Places data. Backup/Restore uses the JSON format, and is a complete backup of all Places data.

Ideally, the HTML format would also contain unfiled bookmarks, which is covered by bug 405936.

Marking INVALID since the Restore option should only support JSON. Resolution of the confusion caused by the ambiguity in the UI is being handled in bug 422919.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
OS: Windows XP → All
Hardware: PC → All
why INVALID ?

when using Beta 5 for the first time, no JSON file.
how to create/restore old bookmark with new profile ?

should be able to restore from *.html backup file ?
(In reply to comment #4)
> why INVALID ?
> 
> when using Beta 5 for the first time, no JSON file.
> how to create/restore old bookmark with new profile ?

If it's a new profile, use the Import option, choose the file, and select the HTML file you want to import.

> 
> should be able to restore from *.html backup file ?
> 

Ugh, yeah the old HTML backups show up in the Restore menu listing. 

We should either:

1. support importing HTML via Restore, with a message saying that your existing bookmarks will *not* be removed.

2. not show old bookmark backups in the restore menu

3. do #2, and add a list of HTML backups to the import menu

(all of these assume also fixing bug 422919, to clarify the formats in the top level menu options)
Status: RESOLVED → REOPENED
Flags: blocking-firefox3?
Priority: -- → P2
Resolution: INVALID → ---
Target Milestone: --- → Firefox 3 beta5
option 2 seems correct, the overlap matters for five days, then it stops mattering
Don't think this blocks, since it's only valid for 5 days from installing, but definitely wanted. Dietrich, feel free to renom if you think I'm out of line, here.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Target Milestone: Firefox 3 beta5 → Firefox 3
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040305 Minefield/3.0pre ID:2008040305

see screenshot.

if this is an intended behavior, this bug should be WONTFIX or INVALID ?

https://bugzilla.mozilla.org/show_bug.cgi?id=422919#c2
WONTFIX, this is intended. Now that bug 422919 is checked in, it's clear in the UI that "import" is for HTML.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WONTFIX
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.