Status

()

--
critical
RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: spectorius, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Yesterday it was ok, and today all my passwords disappeared. Master password is still there and it is the same. Thank god i have backup

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
in firebug i detected an firefox error:

in C:/Program Files/Mozilla/Firefox 3/components/nsLoginManager.js

Cc[contractID] is undefined
[Break on this error] this.__storage = Cc[contractID].
(Reporter)

Updated

11 years ago
Keywords: dataloss
Please attach some logging as described in http://wiki.mozilla.org/Firefox:Password_Manager_Debugging

Perchance have you been using some experimental password storage extension? What extensions are you using?
(Reporter)

Comment 3

11 years ago
> Perchance have you been using some experimental password storage extension?
no

> What extensions are you using?
AdBlock Plus 0.7.5.3
Console2 0.1.9
Download Statusbar 0.9.6.1
Fancy Numbered Tabs 1.1
FaviconizeTab 0.9.7.5
FEBE 5.3.1
Firebug 1.1.0b12
Firecookie 0.0.5
Flashgot 0.8.8
Foxmarks Bookmark Synchronizer 2.0.44.6 (experimental beta for Firefox3)
IE Tab 1.5.20080310
IE View Lite 1.3.3
johnycache 1.0.2
Password Exporter 1.1
PermaTabs 1.7.0
SeoQuake 2.0.11
(Reporter)

Comment 4

11 years ago
Created attachment 309733 [details]
Error Console Log
Error: Cc[contractID] is undefined
Source file: file:///C:/Program%20Files/Mozilla/Firefox%203/components/nsLoginManager.js
Line: 103

That's strange, because that shouldn't fail unless there was some problem during component registration.

Gavin noticed that your install patch is unusual... Firefox normally installs itself into C:\Program Files\Firefox, not C:\Program Files\Mozilla\Firefox... Did you install Firefox in some odd way or move things around?

Also, can you look for C:\Program Files\Mozilla\Firefox\components\storage-Legacy.js, and attach it here?
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> Gavin noticed that your install patch is unusual... Firefox normally installs
> itself into C:\Program Files\Firefox, not C:\Program Files\Mozilla\Firefox...
> Did you install Firefox in some odd way or move things around?

I choose Custom install, cause i have 3 different versions of the FF: FF 2 (can`t remember when was the last run), FF 3 Beta 4 and FF3 Minefield. But on pre beta 3 minefields was very unstable, so when was released Beta 4 RC 1, i installed RC1 and using it until RC2, then released Beta 4, and i installed official Beta 4, and now don`t using minefield.  And i also using Thunderbird.

> 
> Also, can you look for C:\Program
> Files\Mozilla\Firefox\components\storage-Legacy.js, and attach it here?

ok
(Reporter)

Comment 7

11 years ago
Created attachment 309739 [details]
storage-Legacy.js
(Reporter)

Comment 8

11 years ago
> But on pre beta 3 minefields was very unstable

mean pre beta 4 :)
Are passwords still broken if you start in safe mode (see http://support.mozilla.com/en-US/kb/Safe+Mode)? If not, then try disabling extensions one by one until you find one causing the problem?
(Reporter)

Comment 10

11 years ago
I run safe-mode and passwords there. then i go into normal mode and passwords there ;)
So, you can't reproduce this now?
(Reporter)

Comment 12

11 years ago
Yeap, i can`t. And IMHO, this is not an a extension problem, but if it is extension, than it can be IETab, or IE View Lite, or FlashGot, cause they was last updated before passwords disappear.
BTW, maybe this thing is connect. At this moment i can`t see extensions in Add-ons window. All tabs buttons is visible, even languages, but ALL this tabs is now empty =(
Hmm, well, then there's not much else I can think of to do here. I've not seen other reports of this problem, so I can only assume it was caused by something unique to your system and/or profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 14

11 years ago
Justin, I reported this problem last year, and you told me the same exact thing.

The problem is common.

The only thing to note is that the passwords DO come back. Usually with a Firefox restart, although sometimes you have to do a system restart.

From what I'm seeing, it seems that Spect just up and panicked, assuming they were gone for good. They're not.

But this has been an ongoing issue w/Firefox for the last several versions.
(Reporter)

Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 15

11 years ago
Before update to B5 entire content in Add-don manager was disappeared  and i`m pretty sure it somehow connected to password disappear. Also password come back after restart in safe-mode, addons was invisible even their, and none restart firefox none computer helped.
The problem is that there's nothing to work on here. Just a vague problem that can't be reproduced and has no likely or suspect cause. You claim the problem is "common" but I just don't see the evidence for that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 17

11 years ago
If problem is very rare than it`s not a ff bug?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.