Marking mail as unjunk in the junk folder causes it to be deleted

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
--
critical
RESOLVED INVALID
10 years ago
4 years ago

People

(Reporter: ger lanigan, Unassigned)

Tracking

(Blocks: 1 bug, {dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: version 2.0.0.12 

When the Junk Folders properties for "Retention Policy" are set to "Always delete read messages", if a message is marked as Unjunk, it is still automatically deleted.

Reproducible: Always

Steps to Reproduce:
1.Set the retention policy on the junk folder to delete read meassages
2.Mark a message as Junk, automatically moved to junk folder, open the Junk folder
3.Now change the Junk flag using the menu icon, unjunk, the email is automatically deleted
Actual Results:  
The message had the junk status removed, returning to the inbox the message was not there, and on examining the junk folder the message was gone. 

Expected Results:  
Returned the mail to the inbox.

Comment 1

10 years ago
Actually, it's never "moves back" anywhere, only the junk status is changed. (See bug 208197.)

If I read your report correctly, the message was deleted because you had retention policy set to delete all read messages, and that message was marked read, no? (Bug 306739 might have some relation also.)

Comment 2

10 years ago
Currently there is no support for moving messages when unjunking. Unjunking does mark the message as read. So although this is an unfortunate combination it's not entirely unexpected behavior currently.

That said, I'm already working on support for filtering and/or moving messages when unjunking, which should address this issue, so I'll assign this bug to me.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

10 years ago
Assignee: nobody → gwenger
Status: ASSIGNED → NEW

Comment 3

9 years ago
  Geoffrey in comment #2
> Currently there is no support for moving messages when unjunking. Unjunking
> does mark the message as read. So although this is an unfortunate combination
> it's not entirely unexpected behavior currently.
> 
> That said, I'm already working on support for filtering and/or moving messages
> when unjunking, which should address this issue, so I'll assign this bug to me.

Geoffrey, any news on this front?
Assignee: gwenger → nobody
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
(In reply to comment #2)
> Currently there is no support for moving messages when unjunking.

Geoffrey, Bug 208197 is already landed on Tb3.0b2. Bug 466041 is still open.
Duplicate of this bug: 489664

Comment 6

8 years ago
While probably technically correct (unjunk causes read if so chosen, read causes auto-delete if so chosen), this should never happen, regardless of settings.

Half of the solution might be to ensure that we move the msg back to inbox /before/ marking read.

Updated

8 years ago
Blocks: 531787

Updated

7 years ago
Severity: normal → critical
Keywords: dataloss

Comment 7

5 years ago
was this perhaps helped by bug 228949?
Flags: needinfo?(gerlano)
Flags: needinfo?(bugzilla2007)

Comment 8

5 years ago
I don't know how to set Junk Folders properties for "Retention Policy" to "Always delete read messages" - don't see that option anywhere, so can't test.

Note that this might also behave differently for IMAP (which I don't test usually).
Flags: needinfo?(bugzilla2007)

Comment 9

5 years ago
IIRC the UI for that option was removed.

Comment 10

4 years ago
(In reply to Magnus Melin from comment #9)
> IIRC the UI for that option was removed.

Which should make this bug invalid.
Feel free to reopen if you think this was done in error.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

4 years ago
Thanks for looking into this
Flags: needinfo?(gerlano)
You need to log in before you can comment on or make changes to this bug.