All users were logged out of Bugzilla on October 13th, 2018

###!!! ASSERTION: EndUpdateBatch without a begin: 'mBatchInProgress'

VERIFIED FIXED in Firefox 3

Status

()

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: cbook, Assigned: dietrich)

Tracking

({assertion})

Trunk
Firefox 3
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5pre) Gecko/2008031413 Minefield/3.0b5pre ID:2008031413 (Linux Debug Build on Fedora 8)

Steps to reproduce:
- Bookmarked some sets of tabs
- Go to the Places Libary
- Delete this set of tabs
--> Assertion

###!!! ASSERTION: EndUpdateBatch without a begin: 'mBatchInProgress', file /opt/debug/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2488
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x0005EA41]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x000558BF]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x0006A101]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x0007B2B3]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x0007144C]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x00072904]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libplaces.so +0x0007AE8F]
NS_InvokeByIndex_P+0x0000023B [./libxpcom_core.so +0x000D1919]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libxpconnect.so +0x0006953E]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libxpconnect.so +0x000782E4]
js_Invoke+0x00000BBD [./libmozjs.so +0x00098BA6]
UNKNOWN [./libmozjs.so +0x00089490]
js_Invoke+0x00000C36 [./libmozjs.so +0x00098C1F]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libxpconnect.so +0x0006227C]
UNKNOWN [/opt/debug/mozilla/firefox-debug/dist/bin/components/libxpconnect.so +0x00059C1D]
UNKNOWN [./libxpcom_core.so +0x000D2931]
UNKNOWN [./libxpcom_core.so +0x000D19AF]
(Assignee)

Comment 1

11 years ago
I'm not able to reproduce. The STR is ambiguous. Can you please provide a more details set of steps?

How many tabs? And do you mean you used the "Bookmark all tabs" option?

How did you delete the bookmarks? Did you select the folder and delete that, or did you select the group of bookmarks?
I see the same with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040904 Minefield/3.0pre

The errors I see with my debug builds are multiple instances of:

###!!! ASSERTION: EndUpdateBatch without a begin: 'mBatchInProgress', file /Shared/Mozilla/Trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2554

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp&rev=1.138&mark=2554&#2543

Steps to reproduce:
1. Press Cmd+D or star twice to open the bookmark contextual dialog
2. Add some tags
3. Remove a tag

While removing a tag the above assertion is listed multiple times within the console.
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 3

11 years ago
Henrik, a clarification please: When you say "Remove a tag", do you mean that you delete any tag in the tags field of the dialog? Do you get the assertion immediately, or after moving focus to a different control?
I only remove one of the given tags and have to move the focus to another control. But what I see now is, that I have forgotten a step. Please open the library in parallel and place it into the background before you remove one of the given tags. Then the assertion should be really visible to you.
(Reporter)

Comment 5

11 years ago
Created attachment 316038 [details]
better stack
(Assignee)

Comment 6

11 years ago
Created attachment 316314 [details] [diff] [review]
fix

See also bug 405551 for some discussion.

This patch removes the unnecessary batch update. It also changes an assertion to a warning (consistent w/ the other warning there), which allows the xpcshell in debug mode to complete correctly (what i was seeing here: https://bugzilla.mozilla.org/show_bug.cgi?id=405551#c7).

All tests pass with this patch.
Assignee: nobody → dietrich
Status: NEW → ASSIGNED
Attachment #316314 - Flags: review?(mano)
Blocks: 429811
(Assignee)

Comment 8

11 years ago
Comment on attachment 316314 [details] [diff] [review]
fix

drivers: very low risk patch, fixes assertions as well as removing an unnecessary transaction.
Attachment #316314 - Flags: approval1.9?
Comment on attachment 316314 [details] [diff] [review]
fix

a=mconnor on behalf of 1.9 drivers
Attachment #316314 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 10

11 years ago
Checking in toolkit/components/places/src/nsNavBookmarks.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsNavBookmarks.cpp,v  <--  nsNavBookmarks.cpp
new revision: 1.164; previous revision: 1.163
done
Checking in toolkit/components/places/src/nsNavHistoryResult.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp,v  <--  nsNavHistoryResult.cpp
new revision: 1.143; previous revision: 1.142
done
Target Milestone: --- → Firefox 3
Dietrich, can we mark this bug as fixed?
(Reporter)

Comment 13

11 years ago
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042814 Firefox/3.0pre (Debug Build) - i don't see the assertion anymore, thx dietrich :)
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.