Rating stars should not be transparent

RESOLVED FIXED

Status

()

Firefox
Theme
P2
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: mossop, Assigned: faaborg)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by 429689])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
The rating stars in the get add-ons section of the add-ons manager are currently blue for a filled in star, and a blue outline with a somewhat transparent fill.

This is something of a problem because the colour of a selected list item is blue, so it looks like any selected item is rated 5.
Flags: blocking-firefox3?
Apparently this will be fixed with the next icon drop.
Assignee: nobody → faaborg
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
(Assignee)

Comment 2

10 years ago
Created attachment 310592 [details]
New stars, still needs some work

Here are the stars.  Better, but still isn't working that well on luna silver.  We might try a purple star or something.  The issue isn't transparency as much as creating a clear distinction between active and inactive given the range of possible background colors.
I'd probably land these and resolve the blocker, and figure out Luna Silver if we have time to do so.  Otherwise we're done, IMO.
Whiteboard: [needs status update]
(Reporter)

Comment 4

10 years ago
These still look like they will be almost indistinguishable on a white background, which is what the unselected background is essentially everywhere as I recall?
(Assignee)

Comment 5

10 years ago
Yeah, we still need to fix this.  Icon revisions aren't on any developers critical path, since I'm managing feedback with the Iconfactory and generating the set of files to land is now automated.   There is no need for us to start preemptively resolving bugs that still need to be actually addressed.
Who said anything about preemptively resolving?  From the comments I assumed these were ok.  So what's the ETA on resolution here?

Updated

10 years ago
Duplicate of this bug: 424903
(Assignee)

Comment 8

10 years ago
>From the comments I assumed these were ok.

Sorry, several of us had realized that these were still broken, but that was out of band of the sequence of comments.  Mossop notes the problem in comment #4.

This isn't the highest priority icon change right now, but we should have it resolved in one of the drops before RC1 on Tuesday.
Whiteboard: [needs status update] → [eta on icons?]
(Assignee)

Comment 9

10 years ago
>[eta on icons?]

new icons should land in 24 to 48 hours.

Updated

10 years ago
Whiteboard: [eta on icons?] → [waiting on icons][ETA 4/15]
faaborg, its been 120 hours, status?
(Assignee)

Comment 11

10 years ago
The icons were included in the set of chopped up files which is why they didn't make the last drop.  I'm landing them now.
(Assignee)

Comment 12

10 years ago
sorry, were/were not
This is now fixed, new icons landed with the latest windows drop.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [waiting on icons][ETA 4/15] → [fixed by 429689]
You need to log in before you can comment on or make changes to this bug.