If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Addon Window buttons fail: AddonsViewBuilder is undefined

RESOLVED DUPLICATE of bug 419929

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 419929
10 years ago
9 years ago

People

(Reporter: John J. Barton, Unassigned)

Tracking

Trunk
mozilla1.9beta4
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
In 3b4 the addon window is not populated and the buttons don't work. The error is

debugger.onError: AddonsViewBuilder is undefined
<top>
(0)chrome://mozapps/content/extensions/extensions.js:238-458@431
(0)chrome://mozapps/content/extensions/extensions.xul/event/FPxbVhS%2BKFW1AXRhpIEdJQ%3D%3D:1-2@1
<bottom>
What are the steps to reproduce this?
(Reporter)

Comment 2

10 years ago
Sorry, didn't finish my job, did I. 

Firefox->Tools->Addons
I'll attach an image
Then on the Add-ons window, click on Extensions button on top
Another image for that.

I have two extensions loaded for sure so the view is incorrect.
(Reporter)

Comment 3

10 years ago
Created attachment 309780 [details]
Window that popups up from Firefox->Tools->AddOns

Extensions should be listed; they aren't
(Reporter)

Comment 4

10 years ago
Created attachment 309781 [details]
Clicking Extensions button on top of Addon window

Should show two extensions.
Is this totally reproducable?
Is it exactly 3b4, not a nightly or a non-official build?
What extensions do you have?
Does it happen in safe mode or a new profile?
Is anything displayed in the error console with chrome errors enabled?
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> Is this totally reproducable?
 Yes every time
> Is it exactly 3b4, not a nightly or a non-official build?
 Standard issue 3b4, and the same thing has happened for previous betas.
> What extensions do you have?
 Firebug and Chrombug
> Does it happen in safe mode or a new profile?
 I would not expect it to happen, since it can't show extensions when there are none.
> Is anything displayed in the error console with chrome errors enabled?
> 
As I posted.

This view has never worked for me so I thought maybe it just was not working yet. If this behavior is a surprise to you, then there must be something about chromebug that is an issue.
(Reporter)

Comment 7

10 years ago
When I start FF3b4 after FF2 and immediately Firefox->Tools->Addons it works. In this case the compreg.dat is re-built.

If I restart FF3b4, then Firefox->Tools->Addons, I get these errors:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://mozapps/content/extensions/extensions.js :: <TOP_LEVEL> :: line 71"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIPrefBranch2.addObserver]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://mozapps/content/extensions/extensions.js :: Startup :: line 988"  data: no]

See also 408412 and 421392
(Reporter)

Comment 8

10 years ago
Now this is getting weird. I crashed FF3b4. On the next run and so far since then the Addon window works. I would just say "Oh, bad profile", but remember Addon window has never worked for me. (Looks cool now that I can see it ;-).

One  error in Error Console:

Error: Warning: unrecognized command line flag -jsconsole

Source File: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%204/components/nsBrowserContentHandler.js
Line: 695
and the console did not come up on it own. Chromebug does some funky stuff for the jsconsole. Let me run without it for a bit.
(Reporter)

Comment 9

10 years ago
Ok I hit this error and avoided it several times now. Every time I hit the error I had the import exception.  Turns out there is a another report on the import problem, 419929, which is identical to my case.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419929
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.