Library search results don't refresh after clearing search box contents

VERIFIED FIXED in Firefox 3

Status

()

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: kareem.johnson60+bugzilla, Assigned: mak)

Tracking

Trunk
Firefox 3
x86
Windows Vista
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008031405 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008031405 Minefield/3.0b5pre

Search functionality bug:
When searching for a bookmark using the built-in search box, removing the search query text by clicking the 'x' does not refresh the search results. Only items from the search query are displayed, despite the search box being blank. My current workaround is to refresh the view by changing the selected search folder.

Back/forward functionality bug:
The forward button never activates, and therefore I cannot browse forward into history.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



My setup includes the google notebook, foxytunes, passwordmaker pro and ie tab extensions. I will qualify this bug with a test running no add-ons.
(Reporter)

Comment 1

11 years ago
loaded firefox in safe mode, bugs remain.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
(Reporter)

Comment 2

11 years ago
the back/forward func. is being address by bug 408860
(Assignee)

Comment 3

11 years ago
confirmed here, clearing search does not restore original results
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: bookmarks manager search, back/forward functionality broken → Library search results don't refresh after clearing search box contents
(Assignee)

Updated

11 years ago
Severity: major → normal
(Assignee)

Comment 4

11 years ago
Created attachment 317293 [details] [diff] [review]
patch

Steps to reproduce.

1. Select a folder in the left pane(for example Bookmarks menu)
2. search for "moz"
3. clear search field (with canc or clicking the clear search button)

actual result:
you see all bookmarks menu contents as uri, you have to select another folder and come back to see again the original content

expected result:
you see the correct bookmarks menu contents

When the user clears the search field we call onPlaceSelectedURI(false) but the _content.place has not changed, so we don't refresh the view, we should instead since we are expecting different contents.

I hope we can take this for the final since it's really a big annoyance against search functionality in the Library
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #317293 - Flags: review?(mano)
(Assignee)

Comment 5

11 years ago
probably not a real blocker, but imo should be wanted
Flags: blocking-firefox3?
Comment on attachment 317293 [details] [diff] [review]
patch

r=me, thanks
Attachment #317293 - Flags: review?(mano) → review+
(Assignee)

Updated

11 years ago
Attachment #317293 - Flags: approval1.9?
Comment on attachment 317293 [details] [diff] [review]
patch

a1.9=beltzner
Attachment #317293 - Flags: approval1.9? → approval1.9+
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Whiteboard: [has patch][has review][has approval]
mozilla/browser/components/places/content/places.js 	1.159
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch][has review][has approval]
Target Milestone: --- → Firefox 3
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008042407 Minefield/3.0pre.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.