Memory Leak Report from Leak Gauge for Firefox 3 Beta 4 RC2 with Adblock Plus installed

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({memory-leak})

Trunk
x86
Windows XP
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 309839 [details]
leak gauge log

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4)
Gecko/2008030714 Firefox/3.0b4

As discussed with Jonas, this is a spin off from Bug 421703 for the second leak gauge log.

As Steps to reproduce i installed as Part of the Smoketests for Firefox 3 Beta 4 RC 2 the Adblock Plus Extension from AMO (https://addons.mozilla.org/en-US/firefox/addon/1865) and surfed a little around to test the extension. I was also on the heise website (http://www.heise.de)

After this i closed Firefox to check the Leak Gauge Log and got the Leak Gauge Log Result Output:

Results of processing log leak3.log :
Leaked outer window 211bcc0 at address 211bcc0.
Leaked outer window 1219280 at address 1219280.
Leaked inner window 1219430 (outer 1219280) at address 1219430.
 ... with URI "about:blank".
Leaked content nodes associated with node info manager at address 238a3c0.
Leaked content nodes associated with node info manager at address 1ae2d60.
 ... with document URI "http://www.heise.de/".

Summary:
Leaked 3 out of 105 DOM Windows
Leaked 0 out of 112 documents
Leaked 0 out of 35 docshells
Leaked content nodes in 2 out of 122 documents

David could you a take a look at the log ?
Flags: blocking1.9?
Again, marking blocking pending investigation by david.  P2.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(Reporter)

Comment 2

11 years ago
was not able to reproduce this leak with the RC2 of Firefox Beta 5, will renom or file a new bug when i run into this leak again
Flags: blocking1.9+

Comment 3

4 years ago
WFM per comment 2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.