[mac] HTML comments appear in the page

VERIFIED DUPLICATE of bug 42270

Status

()

P3
normal
VERIFIED DUPLICATE of bug 42270
19 years ago
18 years ago

People

(Reporter: pierre, Assigned: rickg)

Tracking

({platform-parity, regression})

Trunk
PowerPC
Mac System 8.5
platform-parity, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand.)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Reproduced with today's M17 optimized build (2000-06-12 @ 20h00) and with a debug 
build pulled around 4pm the same day:
- Quit the app if it is running already.
- Launch, wait for the default Mozilla page to display.
- Click the Bugzilla button in the toolbar or enter http://bugzilla.mozilla.org/.
==> The top part of the page displays the following HTML comment all in a single 
block (ie. no linefeeds):
*********
The contents of this file are subject to the Mozilla Public License Version 1.1 
(the "license"); you may not use this file except in compliance with the license. 
You may obtain a copy of the license at http://www.mozilla.org/MPL/ Software 
distributed under the license is distributed on an "AS IS" basis, WITHOUT 
WARRANTY OF ANY KIND, either express or implied. See the license for the specific 
language governing rights and limitations under the license. The Original Code is 
the Bugzilla Bug Tracking System. The Initial Developer of the Original Code is 
Netscape Communications Corporation. Portions created by Netscape are Copyright 
(C) 1998 Netscape Communications Corporation. All Rights Reserved. 
Contributor(s): Terry Weissman, terry@mozilla.org Matthew Thomas, 
mpt@mailandnews.com -->
********

Now the weird things:
- It happens on the Mac but not on Win98 (I did not check on unix).
- If you look at the source, the comment which is displayed is not even the first 
comment in the file.
- It only happens the first time you visit the Buggzilla page. You can launch the 
app and even surf a little bit, go to Bugzilla and the bug is there. Then it 
can't be reproduced until you quit the app.
- It's very unfortunate but it doesn't happen if you load a copy of the Bugzilla 
page saved on your local disk.
(Reporter)

Updated

19 years ago
Keywords: pp, regression
(Reporter)

Comment 1

19 years ago
Created attachment 10039 [details]
screen snapshot
(Assignee)

Comment 2

19 years ago
I landed a fix last night which should have corrected this. Please retry.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

19 years ago
Sorry, the bug is still there in today's daily build (2000-06-13 08:00).

(Assignee)

Comment 4

19 years ago
harish: please take a look. The bugzilla.mozilla page is using html 3.2 as it's 
doctype, so I don't think this is related to the strictDTD.
Assignee: rickg → harishd
Status: ASSIGNED → NEW

Comment 5

19 years ago
Created attachment 10156 [details] [diff] [review]
patch [ This is so silly ;-) ]

Comment 6

19 years ago
Nominating for nsbeta2 ( bugzilla looks bad ). The fix is trivial..and safe.
Status: NEW → ASSIGNED
Whiteboard: Fix in hand.

Comment 7

19 years ago
Reassigning bug to rickg.
Assignee: harishd → rickg
Status: ASSIGNED → NEW
(Assignee)

Comment 8

19 years ago
yet another dup.

*** This bug has been marked as a duplicate of 42270 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.