FF crashes with JavaScript while (true) - Loop

RESOLVED DUPLICATE of bug 370369

Status

()

RESOLVED DUPLICATE of bug 370369
11 years ago
11 years ago

People

(Reporter: jansaure, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

When opening the site FF shows the following behavior:
with PC1 (Win XP, P4 2,4 GHz, 512 MB Ram) FF crashes and I had to kill the task
with PC2 (Win XP, PD 2,8 GHz, 1 GB Ram) FF is usable after 25 seconds
with PC3 (WinXP, P4 3 GHz, 512 MB Ram) and _FF_3_BETA_4_ I have the same behaviour as with PC1
The pagefile increases about 700 MB.
dom.max_script_run_time is set to 10 seconds

Reproducible: Always

Steps to Reproduce:
1. Open the link
2. Click the button on the page

Actual Results:  
same

Expected Results:  
stopping after 10 seconds

the script code:

<html>
<head><script type="text/javascript">
function stringsAddieren()
{alert ("viel Freude");
var s1 = "1234567890";
var s2 = "1234567890";

while (true)
	{s1 = s2 + s2 + s2 + s2 + s2 + s2 + s2 + s2 + s2 + s2;
	document.writeln("s1:" +s1);
	s2 = s1;
	}
}
</script></head>
<body>
<form name="eing">
<input type="button" onClick="stringsAddieren()" value="Start">
</form>
<!-- Ad by funpic.de --><noscript><div style="display:none">&nbsp;</div></noscript><script type="text/javascript" src="http://media.funpic.de/layer.php?bid=34131048"></script><!-- End Ad by funpic.de --></body>
</html>

Comment 2

11 years ago
This bug apparently covers all versions including version 3.  Fx becomes unresponsive, and the script is not stopped after 10 seconds.

Please feel free to reopen the bug if you feel it is NOT a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274593

Comment 3

11 years ago
Sorry, I duped it against the wrong bug.
Duplicate of bug: 370369
You need to log in before you can comment on or make changes to this bug.